1

I have disabled the Dock in the desktop spaces with the following command.

defaults write com.apple.dock autohide-delay -float 1000 && killall Dock

But when an app is in full screen mode, I can still open the Dock when I move the mouse to the screen edge and then move it again in that direction.

How to disable the Dock in macOS High Sierra in full screen mode?

migrated from stackoverflow.com Aug 22 '18 at 8:16

This question came from our site for professional and enthusiast programmers.

1

The best workaround I've found:

defaults write com.apple.dock tilesize -int 1
killall Dock

This makes the dock so tiny that it won't ruin your fullscreen workflow when it does pop out.

  • this hides the dock everywhere (plus you didn't write the command to revert to its original status, if someone tries it) – Magnetic_dud Jan 23 at 9:21
  • defaults delete com.apple.dock tilesize; killall Dock – Magnetic_dud Jan 23 at 9:22
0

You can set the dock to show and hide in the system preferences pane. Go to system preferences and check the box to hide and show the dock. After doing this you can set a time for how long you must hover over the dock pane to make it appear. This is done with the following terminal command: defaults write com.apple.Dock autohide-delay -float 5 && killall Dock. This sets the time to 5 seconds. You can make that number much larger to accomplish what you want.

The details of this answer came from here. This link also tells you how to turn it back on.

  • macos conveniently ignores this setting when you are in full screen. You can set to show it after 1000 seconds, but when in full screen, it will use default settings... – Magnetic_dud Jan 23 at 9:22

You must log in to answer this question.