1

I installed git with brew install git

Now I want to use the update-index parameter, but that doesn't work because git-update-index is not installed.

How can I install this via Homebrew or another way for macOS?

EDIT

I am running macOS High Sierra 10.13.6 with git version 2.18.0 (both currently at the time of this writing).

$ type -a git
git is /usr/local/bin/git
git is /usr/bin/git

I'll check that tomorrow on work, because with my home-mac it works the correct way.

  • Please edit the question to specify the version of macOS installed on your Mac. Also mention the version of git installed (determined by running git --version). You can verify that you are referring to the Homebrew installed git by running type -a git and checking that the 1st line in the output shows git is /usr/local/bin/git. – Nimesh Neema Aug 21 '18 at 17:54
  • Why not use the git included in Xcode? – Mark Aug 22 '18 at 14:41
0

You are possible executing the command incorrectly. There is no git-update-index command.

Instead try, git update-index.

There is no additional steps required to install git-update-index.

  • the executable is here on my home mac: /usr/local/Cellar/git/2.18.0/libexec/git-core/git-update-index - i'll compare it tomorrow – MonTea Aug 21 '18 at 18:14
  • @MonTea That's the default location for git executable installed via Homebrew. – Nimesh Neema Aug 21 '18 at 18:15
  • yeah, but the problem is on my work-mac there isn't that file so the parameter update-index doesn't work.. perhaps i have to deinstall it and reinstall it again... don't know - thank you i'll report tomorrow ;) – MonTea Aug 21 '18 at 18:16
0

My solution to this issue is:

brew reinstall git

After that I got this:

➜  ~ $ ls /usr/local/Cellar/git/2.18.0/libexec/git-core/
...
git-update-index
...

And now the command git update-index --assume-unchanged LocalConfiguration.php which I initial want to use finally works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .