5

I am struggling to use the Web Inspector on my Mac to inspect the webpage on my iPad. This is how I am trying to connect my Mac to my iPad:

  • I have turned on web inspector on my iPad.

  • I have checked that cookies are enabled on both the Mac and the iPad.

  • I have connected my iPad up to my Mac with a cable.

  • On the Mac, under the develop menu I can see my iPad - when I hover the mouse over the visible tab, the webpage on my iPad highlights with blue. Clicking that brings up the Web Inspector on my Mac.

  • When I hit refresh in the Web Inspector on my Mac, the page on my iPad refreshes.

There is obviously a connection between my iPad and my Mac.

However, the rest of the Web Inspector on my Mac seems empty.

The Elements tab is empty. The Network tab shows an empty list (headers only), even after a refresh. The Resources tab is empty. The Timelines tab is empty. The Debugger tab is empty and shows no sources. The Storage tab is empty. And the Console tab shows nothing, despite numerous calls to console.log from my webpage on the iPad.

I have also tried opening a private browsing window on my Mac and tried connecting to my iPad via the Web Inspector from there. Still no joy.

I am using Safari version 11.1.1 on my Mac. I am unsure how to check the version number of Safari on my iPad. Please let me know if there is any further information that I could provide.

Can anyone help me in getting the Web Inspector to work properly between my Mac and my iPad? Many thanks.

  • I am unsure how to check the version number of Safari on my iPad. Edit the post and mention the version of iOS running on your iPad. Also specify the version of macOS installed on your Mac. – Nimesh Neema Aug 21 '18 at 20:21
  • I'm seeing the same thing with a Mac running Mojave 10.14.3 (18D109) and an iPhone on iOS 12.2. See the iPhone in the menu, iPhone screen flashes blue when I hover it in the Mac Safari menu. Web Inspector shows the correct URL in its title, but is otherwise empty of content, as though no page has loaded. If I write 1 + 2 or alert("hi") in the Web Inspector console and submit, nothing appears to happen. No alert, not even a return value displayed on its own line. The reload button in the Web Inspector appears to do nothing. – Henrik N Apr 9 at 12:55
  • I tried rebooting my iPhone; didn't help. Tried restarting Safari, didn't help. Updated (to 10.14.4 (18E226) and rebooted my Mac and now it works. So the fix was likely either the Mac reboot or the update from macOS 10.14.3 to 10.14.4. – Henrik N Apr 9 at 13:38
  • Still experiencing this in 2019, have tried everything and can't get past it. Did anybody find a solution? – Toby Apr 17 at 23:32
  • I never managed to get around this issue - in the end I had to just trial and error it until the problem went away, it was very painful. If you have more luck than I did please let me know. – Jimmery Apr 18 at 12:06

You must log in to answer this question.

Browse other questions tagged .