0

When I'm remote desktopped into other machines or using web browsers that have apps requiring function key usage, my Mac steals the keys instead... I'll hit shift F1 to try to perform an app function, but instead my speakers turn off. How can I disable OS X stealing function key presses meant for applications?

  • System Preferences > Keyboard > Keyboard > [√] Use F1, F2, etc. keys as standard function keys – user3439894 Aug 20 '18 at 13:15
  • It's the same for any Remote operation - you need to remove the conflict at source, which saves you having to remove it at each & every destination. – Tetsujin Aug 20 '18 at 13:28
  • @user3439894 That would be perfect except I do not have that option :-( All I have there are the key repeat, delay until repeat, and "Show keyboard and emoji viewers in menu bar" checkbox – Brian Knoblauch Aug 20 '18 at 13:44
  • @Tetsujin I hear what you are saying, but I don't think that's a viable option in this case. Rewriting multiple enterprise apps to solve a problem that the couple of us odd Mac users have (everybody else is on Windows where this problem does not exist) doesn't seem like the right fit in this case... – Brian Knoblauch Aug 20 '18 at 13:50
  • 1
    Fn/F-key will reverse the F-key functionality usually. idk why you don't have the switch, though, unless it may have something to do with the newer touch-bar MacBook Pros. – Tetsujin Aug 20 '18 at 13:56
0

One thing I did not think of, this is a Razer keyboard, so their software may interfere with normal usage. In this case though, if I put the keyboard into "Game" mode, function keys turn into normal function keys again. I can then also map my volume controls to the macro keys and not lose that function either!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .