I have a German keyboard layout and need e.g. Option+7 to write a pipe (|). Option+Letter (Letter=a..z) works fine, but Option+Number (Number=0..9) is not producing anything. However, if I press Option+n (~) and then Option+7, surprisingly I get ~|. This behavior is only in iTerm2.

The setting in Profiles >> Keys is Left option key acts as Normal and Right option key acts as Normal.

2 Answers 2


I found the solution for this issue but cannot explain why it's working when using tilde before. Maybe because the system is in another sequence/keystroke until…

The issue is, that iTerm uses option + number to invoke the "To switch split panes" command (bottom left corner "Navigation Shortcuts" section). If you remove the key from the settings or use another one, the special chars are working as expected again. Unfortunately you cannot distinguish between the right and left option key for this shortcut so I use the following config:

  • To switch split panes: cmd + number
  • To switch tabs: No shortcut
  • To switch windows: No shortcut

This way I can navigate the split panes with cmd + number and navigate the tabs using cmd + left/right arrow.

This was driving me crazy since weeks :-/ Hope this helps someone!

iterm2 keys


I found my solution here https://gitlab.com/gnachman/iterm2/-/issues/7098

I'm using French - PC input, for that once I checked Emulate US Keyboard, it works fine :D

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .