1

Model MacBook Pro 2010 6,2

OS X version Yosemite 10.10.3

I used createinstallmedia to format and create an install USB stick. This step went fine. Command used was:

/Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/HP-8 --applicationpath "/Applications/Install OS X Yosemite.app"

(One comment was that I need to do this as sudo. The line before was 'sudo bash' so I end up with a root shell.)

Note that if you backslash the spaces inside the quotes it doesn't work. Basic shell stuff, but I'm rusty it took me a bit to figure it out as the message talks about "not a valid installation package." Unhelpful...

When I attempted to boot it, it starts up, I can select the USB stick. When it boots I get the apple logo. The progress bar gets a little over 1/4 of the way, then the screen goes to a grey barred circle ("No") and nothing more happens.

Edit: Booting verbosely the boot fails with [SearchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport!

Searches for this message find mostly forum posts related to hackintoshes.

The copy of installer is one that I've used on several macs, but before I've always been doing upgrades, not install from scratch. (I suspect malware on this one, so I want to zero out the disk before reinstalling.

Note also that this mac has a superdrive. I've vague recollections of a firmware 'feature' that prevented booting an installer off of a memory stick.

  • 1
    does same occur when booting from usb but on a diff Mac? – JBis Aug 24 '18 at 14:49
  • 1
    Have you tried installing an older version of OS X and then upgrading to Yosemite using the application instead of a USB drive? – David Anderson Aug 24 '18 at 17:06
  • 1
    Also, if you download Yosemite again you will get the last released version instead of 10.10.3. This might make a difference. – David Anderson Aug 24 '18 at 17:10
  • 1
    If you want to install macOS from scratch, you could try to install via Internet Recovery Mode, since it doesn't require a operating system. Go ahead and press Command+R on startup and select a WiFi Network or plug in an Ethernet cable, and it should load the Recovery OS after some loading. You should to be able to install macOS from there. – kouwei32 Aug 25 '18 at 16:27
  • 2
    did you try to run checksum on the usb ? – Ruskes Aug 28 '18 at 5:58
1

Tested the USB stick with 3 other laptops, all of which had superdrives. Same failure mode.

Tried a second image on a new stick.

Rebooted the mac with the jump drive not plugged in. Got a grey folder with a question mark -- I think that's 'no system folder'

On a whim plugged the new stick in.

Booted off of this stick just fine. I am now in the process of doing a 3 pass secure erase of the hard drive. Odd results in Disk Utility. Claims that this disk has 19 folders, 59 files, and that 630 MB are in use.

I will add to this answer as I find more information.

-1

The command has to be executed with sudo, as otherwise it will not be able to make system level changes.

sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath /Applications/Install\ OS\ X\ Yosemite.app
  • The creation of the memory stick media went without a problem. If you aren't root, the command fails instantly. If you have a blank memory stick, boot doesn't start. – Sherwood Botsford Aug 21 '18 at 18:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .