About 4 months ago I dual booted High Sierra with ubuntu. I dedicated 20 GB of my hard with default Disk Utility. Recently I tried to merge the partition back, but during this process it failed and after that when I boot the system, it fails to start.

What I have:

  • I have a Macbook Pro 2015
  • High Sierra
  • Filesystem is APFS
  • Encrypted with FileVault

What I don't Have:

  • Access to any Mac system

What I did

  • I tried to use rEFInd maybe it could see the bootable partition (FAILED)
  • I tried to boot from Recovery mode (FAILED)
  • I tried Network boot (FAILED)
  • I tried make a bootable usb with dmg which I downloaded. I translated first to iso (FAILED)

What I want (with priority :-) )

  • If possible to boot current system
  • Some instruction how to make bootable USB (to verify whether I did anything wrong) and Reinstall



3 Answers 3


I know it's while I opened this thread but I finally understand what is the problem and how to fix it.

The problem is that after merging the partitions the Disk Utility somehow destroyed the partition type (APFS partition), and changed it to 'FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFF'. There was similar questions related to my issue here and here.

I imaged the whole disk and installed the OS from scratch and with the instructions mentioned in the links I managed to mount the image and access my data. But it was possible to fix the problem without reinstalling and imaging.

Anyway here is the commands I used after installing new OS to solve the issue on the disk image.

First mount the raw image (I imaged the disk with dd).

sudo hdiutil attach -imagekey diskimage-class=CRawDiskImage -nomount hard.dmg

here is my output, as you can see the third partition type is invalid.

/dev/disk3              GUID_partition_scheme           
/dev/disk3s1            EFI                             
/dev/disk3s2            FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFF 

Get information about disk layout and start and size of each partitions.

sudo gpt -r show /dev/disk3

here is the output

      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  927867256      2  GPT part - FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF
  928276896   48828131         
  977105027         32         Sec GPT table
  977105059          1         Sec GPT header

So I just need to remove the third partition and add it again with the right GUID, I also used the start and size from previous command. the GUID for APFS partition is 7C3457EF-0000-11AA-AA11-00306543ECAC.

gpt  remove  -i  2  /dev/disk3
gpt  add -i 2 -b 409640 -s 927867256 -t 7C3457EF-0000-11AA-AA11-00306543ECAC disk3

You need to first find a way to boot the Mac from a Recovery Mode. This will allow you to see the current state of the internal drive. Hopefully, you will have enough free space which can be used to install High Sierra without altering the current APFS partition. Once you have booted to High Sierra, you can determine if the original High Sierra volume can be savaged.

Another alternative would be to install High Sierra to an external drive.

A third alternative would be to find another Mac with High Sierra and connect your Mac in Target disk mode.


Find another Mac, connect it to your Mac via thunderbolt cable (the wifi option wont work if you cant get into recovery mode).

On the other Mac, open recovery mode and then you should see the other hard drive in disk utility.

If so then you can try to install MacOS on the other drive.

Ifi you dont see it, then you will need to either try to repair the drive or replace it.

  • Unfortunately I don't have access to another mac. probably my last resort is to go to a local repair center and ask them to do. but I wanted to try mysef all the avilable option first :)
    – Arash
    Aug 18, 2018 at 21:15
  • If you have a friend or a family member that has a Mac, you can use theirs. Aug 18, 2018 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .