2

MacBook Pro 13" 2016 Touch Bar version

Whenever I plug an external microphone it's really quiet, what's more changing the input volume in the Sound settings doesn't affect it at all - It's still very quiet but hearable at 0 Volume and exactly the same at full volume.

Volume

Is there any way for me to increase the volume of the external microphone?

PS. It's the same regardless of the device, all 3 different headphone pairs behaved the same

1

The command to set your microphone levels all the way up is this:

$ sudo osascript -e “set volume input volume 100”

Also check your microphones for dust in the mic hole and if there is a power source on the device you may need to plug it in. It may need the built in mic amp.

If that doesn't help possibly a 3rd party free app like Soundsource that gives you sliders to toggle Speaker/Microphone levels from the menu bar. I've never used it but found it referenced in the apple forums.

  • Both set the input volume as if I was changing it in the settings, but didn't affect the actual volume. It cannot be dust, the headphones are brand new and it behaved the same with all the other pairs – Krzysztof Wende Aug 17 '18 at 22:41
  • How are you testing the mic volume? Are you relying on a piece of software? Did you check the MIC works on other computers(incase of a manufacturer defect)? Some programs have noise cancelling and volume auto-adjust as a feature like skype or google hangouts. Are you relying on them? – Don Richards Aug 30 '18 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .