3

A few minutes ago I added a small PDF to iBooks on my Mac (DRM-free, not purchased through iTunes). My Mac has iCloud Drive enabled.

My understanding is that this should cause it to be uploaded to iCloud Drive, and thus available on iCloud.com. However, when I log in to iCloud.com, there is no PDF available in iCloud Drive.

Today I also enabled iCloud for iBooks on my iPhone. The PDF is not available there either.

(In iTunes on my Mac, I still have the iPhone set to sync books with my Mac. I was planning to turn this off once I confirmed that iCloud Drive was working. But I don't think that matters here. Bonus points if you can provide any advice on the impact of changing that setting, though I'm pretty sure it should be obsolete once everything is using iCloud.)

Do I have to wait some undetermined amount of time for this to propagate? Any way to make it manually sync so I can confirm it is working?

1

Well, it turns out the answer was rather simple. I had iCloud enabled on my Mac, but it was not specifically enabled for iBooks. (Perhaps it was initially disabled because it is a new feature in recent versions of Mac OS).

I went to System Preferences -> iCloud -> iCloud Drive (click on Options...) -> click the check box next to iBooks to enable it.

After doing this, I immediately saw my PDF in iBooks on my iPhone (the one that I had added to iBooks on my Mac). I did not see the PDF within the iCloud Drive folder on iCloud.com, but I guess I can treat that as a separate issue since at least I've confirmed the sync worked.

0

I had the same problem as you and many others. Now, I have solved it simply by having Books and System Preferences opened AT THE SAME TIME on my Mac, then I went into System Preferences/iCloud/iCloud Drive options and toggle Books on->off->on.

While toggling, I can see the books in Books app disappearing and reappearing. Then those books started appearing on my iPhone Books app as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .