0

Hello I have two routers in my net. One is from my ISP and secound is air port. I want to do port forwarding. If I forward port on air port it doesn't work I have to also forward ports on router from ISP. I have a static ip address on airport. I also tried to turn on DMZ on router from ISP and add an airport ip address. On http://www.canyouseeme.org/ I got success when I have turn on DMZ, but I cannot connect to disk on airport using external ip address. I don't know what should I do :/

  • What you want to do is find out how to put the isp’s router in bridge mode. Then you’ve effectively turned it into a modem only. Then you can route like a pro from the AirPort. You may need to ask the isp to bridge mode for you... rest assured you won’t be the first to ask. – Tyson Aug 14 '18 at 18:30
1

You should only be using one router/firewall.

The problem with using two routers is you set up a double NAT scenario. What is basically happening is that you forward one port from the edge router (the one from your ISP) to the internal router (Airport) which then has to port forward again.

For instance, using ssh port 22 as an example, you would have to forward port 22 on the ISP router to the Airport which then needs to forward port 22 to the host that's accepting the incoming connection (like your Mac).

Can things work in the above scenario? Sure, but it adds several layers of complexity.

What you should do is one of the following:

  • Disable the firewall on the Airport and let the edge router handle all of the port forwarding

  • Disable the firewall on the edge router (turn it into a gateway) and use the firewall services on the Airport

You should also avoid the use of a DMZ. This is an exposed area of your network that allows all connections/ports to pass. It's analogous to the front porch of a house - it's part of the house but nothing is secured behind the front door.

  • I disable DMZ and firewall on the router from my ISP, but it still doesn't work. Tomorrow I'll call to ISP to put the router into a bridge mode as Tyson wrote. – Michał Urban Aug 15 '18 at 19:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .