0

I've hooked up my new Mac Mini to my 47" LG tv with an HDMI cable. Everything works fine, however there's one problem: I get this weird white glow around text (especially "os x native text") like this:

enter image description here

I set the output to 720p (the problem is even worse at 1080p).

Does anyone know how to fix this?

Thanks!

  • Did you try another cable yet? – nohillside Dec 10 '11 at 11:49
  • I have the same problem when my 24" 1080p HDTV/monitor is connected to the HDMI of my computer. I tried it both ways: VGA and HDMI. Tiny text is much clearer using the VGA than it is with HDMI using my AMD 7700 video display settings. Actually, with the AMD Catalyst control software disabled, the text was equally sharp with both VGA and HDMI. How can I explain THAT! Reducing the "sharpness" control on my monitor did reduce the glow behind the text, but it did not help with making the text clearer. – user64283 Dec 7 '13 at 3:30
7

Check if your TV has a “sharpness” setting, and if so turn it all the way down. “Sharpness” is an image filter which can improve the appearance of weak analog signals or rescaled video, but it would produce the kind of bad result you are seeing.

  • More often when using a computer connected to a TV, you should turn on a "Game Mode", or any other mode that disables all special rendering functions of the TV. – Jason Salaz Jan 9 '12 at 17:10
  • Thanks for the tip turning down the sharpness got rid of the text halo on my Sony 40" 1080p LCDTV connected to a Mac Mini via HDMI. – malhal Jan 27 '14 at 18:36
1

For future readers: at least on Samsung TVs, you should try switching the display resolution and framerate to exactly what the TV supports. I.E. if the TV's native framerate is 60 fps then don't set the output to 50 fps in PAL mode but to 60 fps in NTSC.

Alternatively, set the framerate to half of what the TV supports, i.e. 30 fps for a 60 fps TV. This can be especially effective when using a graphics card that doesn't fully meet the requirements of the monitor.

Solved the problem completely for me, no need to adjust the sharpness.

0

Just got rid of the problem. I have got Philips 43PUS6501 and NVidia GT 730 2GB DDR5, both running on 4k/UHD. Everything was OK, except some yellow glow around text on white background (Clear Type turned off).

It's because the nVidia to run on 60Hz, forces output to CROMA 4:2:0, and that greatly impacts text sharpness. Lack of color depth can lead to muddy text on certain backgrounds. Switching to 30Hz on old HDMI cable turns down the amount of data that is sent over the cable by half. Remember, that running 4K/UHD@60Hz at 4:4:4 uses over 12Gbits of transfer, and the old HDMI cables run max 10.1Gbit.

The problem is that I have some old HDMI cable, it's v.1.4, but now the HDMI V.2.0 Cable is on it's way. :) Till then I set refresh rate in nVidia Control Panel from 60Hz to 30 Hz, and the glow is gone.

  • How can you tell what sort of hdmi cable you are using? – WendyG Dec 28 '17 at 21:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .