Recently when I use the terminal and I type a command, I hear a click and whatever I had typed becomes capitalized. If I'm typing ls -lrt I'll hear a loud click and when I look at my command it has changed to Ls -lrt. The same with pwd or any command I type. The capital letter will work on some commands but not all. Does anyone know how to turn this off? I went to System Preferences/keyboard/text but the selection there to use automatic capitalization is not checked. I may have inadvertently done this with Better Touch Tool but I can't find anything about it in the app. Any help would be greatly appreciated.

  • It does it on a webpage to when I try to enter something.
    – Natsfan
    Aug 13, 2018 at 20:47
  • How do I get in Safe Mode.
    – Natsfan
    Aug 13, 2018 at 20:47
  • No, the problem doesn't appear when I'm in safe mode
    – Natsfan
    Aug 13, 2018 at 21:11
  • It's something that's being loaded. Look at your login items (System Prefs -> Users) and see what's being loaded. You can disable items that look like they will cause issues. If you post a list, we can at least hazard a guess.
    – Allan
    Aug 13, 2018 at 22:58
  • I have a bunch. How would i get a list?
    – Natsfan
    Aug 13, 2018 at 23:14

1 Answer 1


Well I found the solution with help from @Allen. I tried restarting my computer in Safe Mode. The problem with capitalization went away. Based on this result it was probably due to something I loaded onto my machine. While I was in Safe Mode I started by looking at the Startup items found in the System Preferences/User and Groups. I hadn't carefully checked the Login Items in quite a while and I found out I had many. Some of these were suspicious in that the kind of item was unknown. I show this in the images below:

enter image description here

enter image description here

I had several that fit that description. Using the minus symbol shown in the bottom left of the window I deleted the suspicious login items and rebooted my computer back to regular user mode. To my joy the auto capitalization was gone. I deduce it must have been connected to one of the login items I removed. Had I removed them one-at-a-time I might have beem able to determine which one was the culpit. As it is I can only narrow it down to the ones I removed. None of these were new additions so I must have changed settings in one of these to suddenly cause my troubles. Due either to old age or the fact that auto capitalization was driving me crazy, I can't recall what changes were made recently. I may go back and try to determine which specific one was causing this but that is left for a future date.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .