8

Recently I have noticed my MacBook Pro restarting as soon as it tries going to sleep. If I plug it in and leave it on for the whole day, it will work fine.

  1. I have tried resetting SMC, NVRAM etc.

  2. Apple Hardware diagnostics says there is no issue with the machine.

  3. First Aid says disk is okay.

I have also tried going into Recovery and deleting the sleepimage. Now have hibernate mode disabled. Still facing kernel panic.

This is what I am getting in the log.

*** Panic Report ***

panic(cpu 0 caller 0xffffff7f9a41ffcd): "Failed to quiesce supporting devices\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleACPIPlatform/AppleACPIPlatform-281.70.3/AppleACPIPlatformPower.cpp:1970
Backtrace (CPU 0), Frame : Return Address
0xffffff9216e739c0 : 0xffffff8018c6c1c6 
0xffffff9216e73a10 : 0xffffff8018d95274 
0xffffff9216e73a50 : 0xffffff8018d87544 
0xffffff9216e73ac0 : 0xffffff8018c1e1e0 
0xffffff9216e73ae0 : 0xffffff8018c6bc3c 
0xffffff9216e73c10 : 0xffffff8018c6b9fc 
0xffffff9216e73c70 : 0xffffff7f9a41ffcd 
0xffffff9216e73cd0 : 0xffffff7f9a41fb9e 
0xffffff9216e73d20 : 0xffffff7f9a4240eb 
0xffffff9216e73d40 : 0xffffff80192b9658 
0xffffff9216e73d90 : 0xffffff80192e7a03 
0xffffff9216e73e00 : 0xffffff801928154b 
0xffffff9216e73e50 : 0xffffff801927e738 
0xffffff9216e73eb0 : 0xffffff801927b713 
0xffffff9216e73ef0 : 0xffffff801927b5a2 
0xffffff9216e73f30 : 0xffffff8019297ef2 
0xffffff9216e73f70 : 0xffffff801929752c 
0xffffff9216e73fa0 : 0xffffff8018c1d557 
      Kernel Extensions in backtrace:
         com.apple.driver.AppleACPIPlatform(6.1)[B0282791-F78C-3A3D-A829-629AD847C7EA]@0xffffff7f9a414000->0xffffff7f9a4affff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[95DA39BB-7C39-3742-A2E5-86C555E21D67]@0xffffff7f99948000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[AEA4C7F5-CCB0-338B-B471-CF28A9792522]@0xffffff7f99494000
            dependency: com.apple.driver.AppleSMC(3.1.9)[2D1E4A3F-A19E-3F12-878D-807CB79CD55F]@0xffffff7f99951000
BSD process name corresponding to current thread: kernel_task
  • 1
    I also get this problem when sending my mac to sleep, did you ever find out about any solution? – Sevyls Oct 16 '18 at 7:56
  • Did either of you try a new OS load? Do you have any 3rd party drivers (printers etc...) that might be causing problems?? I would try it with a new OS load from the internet recovery and a wiped disk with no 3rd party apps installed and see if that works. If so its a software issue of not then its a hardware issue. – Thomas Nelson Jul 21 '19 at 2:21
  • Can you provide the output of the following command pmset -g log when this issue happens? – AbsterT Aug 21 '19 at 4:13
  • This clearly is a PCI device error. – Prado Aug 29 '19 at 11:32
  • I had tried a new OS load, clean HDD OS load, backup from Time-machine, nothing seemed to work. then one day it just stopped crashing. been working fine ever since. not sure what i did to fix it! – Maaribou Aug 30 '19 at 13:00
1

Do you happen to have the GPU problem stated here? If you do please do take care of Part 2: improve thermal and power management.

|improve this answer|||||
  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Answers should be self-contained so others can find them by using the search feature. Links can change and become outdated so we prefer the answers to not just be a link. See How to Answer on how to provide a quality answer. - From Review – fsb Nov 11 '19 at 21:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .