1

I have used this guide on Medium to use the screensaver as wallpaper.

I just got a new iMac at work with macOS v10.13.6. and was intending to do the same. But running the command in terminal with -background doesn't open the screensaver in the background anymore. Instead it's opening it in the front. I can still click stuff on the screen, but I can only see the screensaver.

/System/Library/CoreServices/ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine -background

Does anybody knows if the -background flag has changed?

  • Make sure you have a trailing &. The full command should be /System/Library/CoreServices/ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine -background & – sansSpoon Aug 13 '18 at 1:40
  • 1
    no the trailing & caused the terminal also to move the process to its background. In my case, I would have to restart the mac since I can't see anything but the screensaver... Without the & I can at least still cancel the app from the terminal with ctrl+c – Han Che Aug 13 '18 at 11:11

You must log in to answer this question.

Browse other questions tagged .