1

I have recently taken over a 2017 MBP from a colleague. Apparently I was given a complete base re-install of OSX and upgraded to High Sierra, i.e. all previous custom configurations were reset. However I am unable to change my screen saver from Flurry, to any of the others provided by OSX e.g. Nat Geo.

I created another admin user (i.e. with same permissions) and tried it as that user, and still the same problem. I have full admin privileges and cannot change my screen saver, wow. Seems then this is a system issue, not user specific.

Have deleted com.apple.screensaver.plist from both my account and the system but no joy.

Any idea how to solve this?

  • Check if you have a file at this path: /System/Library/Frameworks/ScreenSaver.framework/Versions/A/Resources/Computer Name.saver. If yes, try after double clicking and installing it. – Nimesh Neema Aug 12 '18 at 13:11
  • You might also need to delete: ~/Library/Preferences/ByHost/com.apple.screensaver.<UUID>.plist – sansSpoon Aug 13 '18 at 1:55
  • Thanks for the suggestions but these two suggestions above have not fixed the issue. – TessN Aug 15 '18 at 4:55

You must log in to answer this question.

Browse other questions tagged .