4

I recently installed iTerm on both my Mac Pro & MacBook Pro and the text selection behavior is different on both the machines.

Consider the following line in terminal:

/Users/user/basic/Libraries/A/B/c.h:282:17: .fish = @"FISH",

Double clicking on "Users" can result in the two possible behaviors:

  1. selects "/Users/user/basic/Libraries/A/B/c.h"
  2. selects "Users"

The behavior is as follows:

  • Terminal: 2 (both Mac Pro & MacBook Pro)
  • iTerm: 1 (MacBook Pro), 2 (Mac Pro)

I am not sure what I am doing on the two different machines. All my configuration files are the same. The actual iTerm configuration is practically untouched.

What setting is responsible for this? I really want behavior #1 on my Mac Pro as well.

Edit 1: I have already looked at Smart Selection and I don't see any difference in settings.

7

Alright I solved this. Somehow, this setting was missing in iTerm on my MacBook Pro.

iTerm Settings

  • 1
    You, sir, have solved the very question that has been nagging me for a long, long time! – TCSGrad Sep 13 '18 at 21:28
  • Maybe because the link to the image is dead, I cannot see it. I found an option "Double click performs smart selection" in iterm -> preferences -> pointer. That solved my problem. It seems the default is '4 successive clicks to perform smart selection' – fstang Jul 5 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .