1

This question already has an answer here:

as part of my update routine, I wanted to upgrade from the installed Java SE 8u171 to Java SE 8u181. Before anyone asks, yes, one software DOES need Java (LibreOffice).

Problem is, the install window abruptly closes, and the installed version stays at 8u171, according to the Java preference pane.

In a terminal windows, I found things even more confusing:

$ java -version java version "1.8.0_161" Java(TM) SE Runtime Environment (build 1.8.0_161-b12) Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)

I don't know exactly what is happening. Console doesn't say why it's failing. I already tried to manually install 8u181 from the .dmg found on Oracle's website, but the result is the same. Same goes when I try to install the update in Safe Mode.

Any clues?

marked as duplicate by Mark, grg Aug 19 '18 at 13:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

Solved. Basically, I forgot that I had to install not the JRE, but the JDK as a workaround for some LibreOffice bug. The JDK does not allow updating through the Java preference pane.

As soon as I manually updated the JDK, the Java preference panel said I had the correct, 8u181 update.

Not the answer you're looking for? Browse other questions tagged .