I'm on a 2016 MacBook Pro with macOS High Sierra 10.13.5. Yesterday, due to the huge amount of 'Purgeable' storage present on disk, the system started to 'purge' it, freeing about 200GB of space. In doing so it also apparently removed many local copies of the iCloud Drive files (I have Documents and Desktop sync'd), as the little cloud appeared next to many of them.

At the same time the Finder started to try and upload 22GB of files (crazy because they were all up there in iCloud Drive). I sought help from Apple and they make me deactivate iCloud Drive (which created a folder with all my files -except for the iWork and similar files, in the Home folder).

Upon reactivation iCloud Drive is not making any progress with the download... files are not reappearing.. folders neither.. The 'expert' said that if I paste the iCloud Drive (Archive) folder inside it will only create duplicates.

What can I do? How can I solve this? My last resort is to back restoring the system from Time Machine but I would like to know why iCloud Drive is not downloading the files.

Thank you very much

  • Here's a fairly good summary of what can happen when you deactivate Desktop and Documents to iCloud. See if it helps you. In the meantime, what exactly are you referring to as "reactivation" of iCloud drive? Do you mean signing back into iCloud after being signed out, or do you mean re-checking the Documents & Desktop box after clicking Options next to iCloud Drive in the iCloud prefpane?
    – Trellis
    Aug 9, 2018 at 15:18
  • I mean checking back iCloud Drive after checking it out. Documents & Desktop were always checked and I didn’t touch them. Aug 9, 2018 at 15:20
  • In iCloud Drive options, what is the status of the two check boxes 1) Desktop & Documents (in the list), and 2) Optimize Mac Storage (beneath the list)?
    – Trellis
    Aug 9, 2018 at 15:26
  • 1
    Now the files are starting to reappear... just I do not understand why it took two hours even just to show the icons (the files will be downloaded over the next 7-8 hrs, it seems) Aug 9, 2018 at 15:28
  • Glad to hear it, I would suggest saving a link to that support article for reference, if you hadn't already seen it.
    – Trellis
    Aug 9, 2018 at 15:31

1 Answer 1


I see you've resolved your situation, but I wanted to write up a formal answer.

When you enable iCloud Drive, it has to go through a (very slow) process for each container of files before they show up. Each App Folder is one such container, and then all standalone files including Desktop and Documents goes in a generic container.

If you have lots of files (10+ GB can cause this to start happening) it can take hours (or days) before the files show up, even though they haven't even started downloading. In this time sync will not finish. If you have just enabled iCloud drive (either on a new computer or because you had turned it off) and you have a lot of files, trying to leave it plugged in etc. may help it go faster. Do not try to turn it off and then on, because it'll just start over.

I'm not sure why this happens, but it's the way it works right now. So if you don't see files after turning it on, let it sit for at least a day or two of having proper power and internet connection before trying other things.

  • 1
    Exactly the same behaviour. I have 100GB+ worth of files on iCloud and after macOS resets, it takes almost a day before the files show up.
    – sivabudh
    May 26, 2019 at 13:55
  • 1
    After a fresh (beta) macOS Catalina installation I noticed this wasn't a problem any longer. It took up to 5 minutes before 300gb worth of storage was visible in the Finder. For some reason I think they solved this issue in the new version. Jul 1, 2019 at 0:38
  • @NMENewMediaEntertainment having the same issue on catalina 10.15.2. 200gb of icloud drive data is not showing up, gigabit ethernet, waiting for 3h already Jan 3, 2020 at 14:57
  • @radu-ursache Early Catalina betas included a different syncing system which was removed and indefinitely delayed.
    – Ezekiel
    Jan 4, 2020 at 15:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .