4

Within the last few weeks I have noticed that my system has stopped or cannot save passwords. Outlook, iCloud, and other GUI apps ask for them every single time. Attached is a picture from SequelPro when attempting to save a password.

How can I diagnose / repair the Keychain?

enter image description here

2 Answers 2

0

Warning: macOS no longer supports Keychain repair, instead it just creates a new default Keychain, which will result in a loss of all saved passwords.

  1. Quit all open applications that might be using Keychain including Sequel.

  2. To try to repair the Keychain use Finder to go to /Applications/Utilities.

You can also CommandShiftU from Finder to open that folder directly.

  1. Launch Keychain Access.

  2. Then go to the menu bar and select Keychain Access > Preferences.

  3. Click "Reset My Default Keychain"

Follow any instructions beyond this and retest those applications.

2
  • 1
    I tried this, but it just say "Unable to obtain authorization for this operation."
    – Kevin
    Commented Aug 9, 2018 at 13:08
  • I recently had a stubborn keychain. I've solved this in the past usually with more grace, but this last time I simply had to completely delete it start over. Sad. Another neglected component of the Apple Desktop Platform. Commented Sep 19, 2018 at 22:36
0

Updating to High Sierra ultimately resolved this. It simply began working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .