1

I've disabled prompts for notifications in Safari but still get them. What do I do? I've got the latest macOS version with all the updates.

Update #1 some screenshots

the prompt settings

  • Is the issue the notifications still come through, or the prompt for notifications. Some websites display their own banners which look like a web browser but aren't part of it. Do you have any screen shots or additional information you can show us. – unknowndomain Aug 9 '18 at 12:05
  • It's regular Safari notifications (even work is frozen until I decide what to do – Sergey Aug 9 '18 at 12:11
  • Again can you please share some more information like screenshots so we have some context to what you are talking about, it's not very clear at all. – unknowndomain Aug 9 '18 at 12:12
  • Done. Don't think that it reveals much – Sergey Aug 9 '18 at 12:14
  • Actually it was, because I thought you were talking about something else... possible answer in a mo. – unknowndomain Aug 9 '18 at 12:18
1

So you've done everything correctly but the notifications are still coming through, there are a couple things to try...

But first please quit Safari, and then do a full reboot, and test again, as even when you close Safari the Safari notification service continues to run in the background.

If you are still having an issue:

  1. Quit Safari.
  2. Go to Finder.
  3. Press CommandShiftG.
  4. Type ~/Library/Preferences into the field.
  5. Press Go.
  6. Find com.apple.Safari.
  7. Move it somewhere safe.
  8. Reopen Safari and reconfigure the Allow websites to ask permission to send push notifications.
  9. Try with one of the problem websites.

This will remove your Safari preferences and will need to be setup again but it may resolve the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .