4

Wi-Fi passwords used to sync between my devices via iCloud Keychain, a wifi password entered on my MacBook would end up on my phone via the 4G connection, and the phone would automatically connect, handy.

As of the last update this doesn’t happen, now I have to bring my phone next to my laptop and tap the share notification to pass it over Bluetooth to get the phone to connect, it’s slow, and half of the time doesn’t work.

Did Apple really scrap the iCloud sync solution to force everyone to use the Bluetooth one that is way more suited for sharing with friends rather than between my own devices?

  • 1
    This Apple Support page is dated 1 month ago and says it's still available. – fsb Aug 9 '18 at 1:12
  • 1
    On my machines (two Macs running High Sierra, and an iPhone SE running iOS 11.4.1), Keychain correctly synchs passwords via iCloud. – David supports Monica Aug 9 '18 at 1:13
  • 1
    You probably just need to log out and back into iCloud on your devices. I would start with the iPhone, but you may need to do it on both. I always just choose to save whatever I'm prompted to delete or save for, then merge when I log back in. Then the setting for Keychain will be reliable again. – Trellis Aug 9 '18 at 2:14
  • Can confirm it defiantly exists, and I've event had my Wi-Fi disconnect on my phone because I removed the password on my Mac. – unknowndomain Aug 9 '18 at 12:32
  • same problem on new iPhone. No WIFI passwords synched to it. – v3nt Mar 1 at 14:16
2

I bumped into this question when searching for the problem.

And I figured out iCloud didn't set up (or logged in) on my Mac OS X. When I logged in to icloud, KeyChain access created a new tab for iCloud just under the Login tab.

Please be sure, you set up iCloud on your Mac OS X.

https://support.apple.com/en-us/HT208682

1

I had the same problem. Then I looked at the iCloud settings page on my mac and found out that Key chain syncing mysteriously have been unchecked. I checked it and now wifi password syncing seems to work again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .