0

I have an old 13' MacBook Air (2011) with latest OSX High Sierra.

I've tried to enable night shift by installing Night-Shift-on-Unsupported-Macs and after that OSX load is stuck at login screen with mouse, trackpad and keyboard (except Power key) completely unresponsive. Dialog message on that screen says it's trying to connect to Bluetooth keyboard and nothing happening at all.

Here are the exact steps I've conducted, which led to current state:

  1. Rebooted Mac into Recovery Mode by restarting computer and holding down Command+R until Apple logo appeared on the screen.
  2. Disabled System Integrity Protection (SIP) by opening Terminal tool and executing
    csrutil disable
  3. Restarted Mac
  4. Downloaded tools from Github repository and tried to launch GUI installer. It threw error, something like SIP is enabled, please disable SIP to proceeed.
    I doubled checked and rebooted again into safe mode.csrutil disable yielded SIP is disabled.
  5. Booted again into current user. ls -lO /System /usr yielded restricted
  6. After looking into this thread some people said running sudo chown -R $(whoami) /usr/local helped to resolve this issue. I've run this command under current user.
  7. GUI version of github tool still didn't work, although shell script ran with no problem and I rebooted.
  8. Loading took much longer than usual and resulted in the situation described above.

I've tried to reset NVRAM and SMC, did disk check and re-enabled SIP and that did not help. I guess I've broke permissions somehow or harmed integrity of the system in some way.

Is there a way to fix it except complete system reinstallation or backup restore? (I still can load into Recovery Mode)

  • 1
    Can you still boot into Recovery Mode? If yes just reinstall the OS from there. – nohillside Aug 8 '18 at 20:25
  • i've just realised I can reinstall without data loss – icherevkov Aug 8 '18 at 21:14

You must log in to answer this question.

Browse other questions tagged .