1

My Early 2008 Mac Pro has worked pretty consistently for a decade but is now spontaneously restarting. It is running OS X 10.10.5 and I see no core updates available. I have avoided updating the OS any further out of fear of system instability; as of recently the hardware became too old for the latest OS X.

I have not installed new software and I thought the spontaneous restarts were due to Firefox (mostly using this computer for online stuff these days) but then it happened when I was in Safari with Firefox not running. I did a disk check which found and repaired an error, but after that the system still restarted -- though now at least I got a panic log.

Does the log (below) indicate where the problem lies? I have been working through a guide to reading panic logs but thus far I can't figure out the problem -- was it trying to read from a memory address that doesn't exist? If so, why would this happen? Thank you very much for considering this.

[StackExchange says my question looks like spam and won't let me post, so I cut out most of the panic log I had pasted below.]

Anonymous UUID:       3D86AB0F-D83A-EC2C-9940-63A3721B44ED

Tue Aug  7 19:59:11 2018

*** Panic Report ***
panic(cpu 1 caller 0xffffff800d416f72): Kernel trap at 0xffffff800d4179c0, type 6=invalid opcode, registers:
CR0: 0x000000008001003b, CR2: 0x000000007be25000, CR3: 0x000000000fe7d000, CR4: 0x0000000000002660
RAX: 0x000000007be25000, RBX: 0x0000000000000012, RCX: 0xffffff8025653c50, RDX: 0xffffff800d4346d0
RSP: 0xffffff817d46e078, RBP: 0xffffff8184d73d70, RSI: 0x0000000000000008, RDI: 0xffffff817d46e080
R8:  0x7ffffffffffffffe, R9:  0x0000010728abd22c, R10: 0x0000000000000000, R11: 0x00000000e0000000
R12: 0xffffff817d46e080, R13: 0xffffff8024f98e40, R14: 0x0000000000000148, R15: 0xffffff817d46e080
RFL: 0x0000000000010082, RIP: 0xffffff800d4179c0, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x000000007be25000, Error code: 0x0000000000000000, Fault CPU: 0x1

Backtrace (CPU 1), Frame : Return Address
0xffffff817d46dd20 : 0xffffff800d32ae01 
0xffffff817d46dda0 : 0xffffff800d416f72 
0xffffff817d46df60 : 0xffffff800d433e33 
0xffffff817d46df80 : 0xffffff800d4179c0 
0xffffff8184d73d70 : 0xffffff7f8ef1b1e9 
0xffffff8184d73e60 : 0xffffff7f8ef1a5b4 
0xffffff8184d73f20 : 0xffffff800d418b0e 
0xffffff8184d73f40 : 0xffffff800d341f6b 
0xffffff8184d73f90 : 0xffffff800d3424b0 
0xffffff8184d73fb0 : 0xffffff800d411867 
      Kernel Extensions in backtrace:
         com.apple.driver.AppleIntelCPUPowerManagement(218.0)[B659F364-9486-3602-A55E-BD7D8E1815B2]@0xffffff7f8ef18000->0xffffff7f8ef42fff

BSD process name corresponding to current thread: kernel_task
  • I would start looking at the drive (is it a decade old as well?). Try using a utility like DiskDrill (diagnostics are free) to see if the drive is beginning to fail. – Allan Aug 8 '18 at 10:17
  • Thank you, I ran disk utility, which found an error and repaired it. After that the system spontaneously restarted again, but this time, with a panic log. – user298048 Aug 8 '18 at 10:28
  • How about checking the console log for shutdown codes, that'll point you in the right direction. – Maximus Aug 8 '18 at 10:29
  • I had a MacPro1,1 that did the same thing. In my case it was a failing video card causing it (hard to diagnose until the card itself failed fully). I would also look at the power supply or it may even be as simple as just overheating components (have you given the inside a good dust out?). I would also upgrade as high as you can OS-wise - my experience has mostly been improved performance and stability (YMMV). – tunecrew Aug 8 '18 at 14:31
  • Does this help? apple.stackexchange.com/questions/199737/… – bmike Aug 9 '18 at 3:25

You must log in to answer this question.

Browse other questions tagged .