1

I am trying to run Vi (not Vim), because i'm curious about some older commands like :open.

I saw this

https://www.reddit.com/r/vim/comments/1u0q0b/how_to_install_traditional_vi_not_vim_on_os_x/

it mentions

http://ex-vi.sourceforge.net/

and

brew install ex-vi

So I did that brew line.

Then when I tried to run vi, $vi<ENTER> I ran :help and it said Vim!

So I did $which vi<ENTER> and it showed /usr/local/bin/vi

I did this

Apples-MBP:~ apple$ ls -l /usr/local/bin/vi
lrwxr-xr-x  1 apple  admin  29  8 Aug 03:32 /usr/local/bin/vi -> ../Cellar/ex-vi/050325/bin/vi

So it looks like it should be running ex-vi but it's not it's running vim. I can't see why?

I tried Running VI on Lion and it mentions about getting vim to run like vi, but I want vi itself.

I don't entirely trust vim's compatibility mode (vim -Cu NONE), as presenting vi. (like in vim's compatibility mode I see multiple layers of undo with ctrl-r), which I heard that vi doesn't have. So I don't want Vim compatibility mode, I want Vi. I installed it but it isn't running.

How can I run vi and why isn't it running?

  • Have you tried running vi from a new shell? – Lawrence Velázquez Aug 8 '18 at 5:53
  • @LawrenceVelázquez ah I think you're right – barlop Aug 9 '18 at 19:59

You must log in to answer this question.

Browse other questions tagged .