I've got a WD MyBook external hard drive formatted in NTFS with files on it. How can I edit files already on it as well as paste files to it?

I've installing Mounty and when I try to re-mount it read-write I get the following error message:

"Volume "MyBook" not re-mountable. The volume is not re-mountable in read/write mode. Probably it was not clean unmounted before."

I've tried another external hard drive also formatted in NTFS and that works.

I've tried one of the free solutions mentioned in the previous post - How do I write to NTFS drives in OS X?


1 Answer 1


I have faced similar problem with my WD external 1 TB drive formatted as NTFS.

For writing, you'll need to install a proprietary NTFS driver for macOS called Paragon NTFS Driver for Mac.

You can follow the instructions on this support article on WD website, How to Install the Paragon NTFS Driver for Mac.

  • Hmm, thanks but why would Mounty work for one drive but not another?
    – Bhav
    Aug 6, 2018 at 18:23
  • I am not sure about the reason, but I have personally experienced that certain generic NTFS drivers for macOS (like FUSE, NTFS-3G) doesn't work with WD's drives. WD's external drives require installation of proprietary drive for writing/editing files.
    – Nimesh Neema
    Aug 6, 2018 at 18:25
  • I have tried "Paragon NTFS Driver for Mac" as well on Catalina and it halts as well for 2 TB. I waited hours but it was unable to open the external, is it normal to wait that long?
    – alper
    Dec 11, 2019 at 17:48
  • @alper Sorry, I have no idea.
    – Nimesh Neema
    Dec 11, 2019 at 18:11

Not the answer you're looking for? Browse other questions tagged .