15

I'm not sure if I have an issue or if what I am seeing is by Apple-design. I have an iPad Pro (11.4) that I have the Personal Hotspot switched on.

  1. My iPad Pro is active and screen on.
  2. I connect my iPhoneX (11.4) to the iPad Hotspot.
  3. Everything works fine.
  4. I sat working on laptop and then the iPhone X and iPad screen locked. After X minutes I then unlock iPhone to check email etc..
  5. The iPhone X has disconnected from the hotspot and is back to using the cellular plan on my iPhone. If I go to Settings -> Wi-Fi then my iPad is not listed.
  6. To make the hotspot reconnect I have to go back to my iPad and toggle the Personal HotSpot switch (On -> Off -> On).

Is this by design or not? Should the iPhone remain connected if the devices screen lock?

1
  • Been getting the same issue but only since 11.3/11.4. Before that didn't have this "feature". Also getting a lot of general hotspot connection issues at the same time necessitating regular reboots or airplane mode switches to kick it into life.
    – Neil Pike
    Sep 9, 2018 at 20:07

6 Answers 6

8

After further experimentation I found that if I create a Bluetooth connection (pair) between iPhone/iPad it stays connected throughout screen locks etc.

2
  • Confirmed this also works with two Iphones
    – Dannie P
    Jun 24, 2019 at 16:46
  • I’m impressed with this ingenious design and ux by Apple.
    – SLCH000
    Nov 6, 2021 at 16:08
3

Finally a working solution!

Turn off Auto-Lock on your iPhone/iPad. If you set Auto-Lock to "Never", the Personal Hotspot will stay active. Even with screen locked for hours.

No more disconnects after 1 to 5 minutes.

2
  • This absolutely works! Thank you! The auto-lock must disable the hotspot as a power-saving feature.
    – Steven
    Mar 12 at 10:22
  • Would be cool to create a shortcut automation (when plugged and at home -> disable auto-lock) sadly you cannot control auto-lock with shortcut.
    – gagarine
    Apr 12 at 20:27
1

I had the same issue with 2 iPhones. It appeared that iOS 12 is saving power by disabling Hotspot broadcast then the signal disappears afterwards.

To fix this Go to iPhone setting -> 'Battery health' and disable the battery saving mode. You find a small link under 'Peak Performance Capability', the option once disabled disappears and cannot be enabled again.

2
  • you can re enable it again May 18, 2020 at 10:07
  • How do you re-enable the link?
    – avaron676
    Mar 16, 2021 at 14:13
0

I think it's partially by design. Whenever my son wants to connect to my Personal hotspot, I have to open the Personal Hotspot screen, even if it's already on and he's got the network/password saved away. But, I don't have to toggle it off/on.

Also, disconnecting from a hotspot is automatic when the client device sleeps.

1
  • its such a nightmare if you connect a router to the tether May 18, 2020 at 10:08
0

iPhone is trying to save battery when there is no data being transmitted to the connected device, for a given duration, by switch off the hotspot. If you live stream any video in youtube from your connected device, you could get around this problem.

0

I was annoyed by this battery-saving feature of iPhone tethering for over a year. What it normally does is to drop the connection when the traffic was not intensive enough, for example downloading a huge file vs. watching YouTube video with buffering.

After searching around, I found the following methods that actually work!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .