I have a 2017 Macbook Pro and a 2018 Macbook Pro. The target machine has a bigger SSD than the source, so I know it's not a space issue.

I ran Migration Assistant on both machines and the process completely relatively quickly. After it completed I received about 2 dozen files that could not be transferred. The machine than boots into macOS and I start receiving repeated authorizations requests to repair files.

I also receive notice that the keychain needs to be replaced with default.

Should I attempt to boot the source into target disk mode and transfer via thunderbolt?

2 Answers 2


It sounds like your Migration didn't work, even though you didn't get error messages saying so at the time.

I always use either Target Mode or an external disk when I use Migration Assistant. I also don't do the Migration until I've gotten the new computer completely up-to-date, etc. I create an extra "Admin" or other dummy account which I delete later.

I would reset the 2018 MBP, create a dummy account, do all the updates, and then when the system was running perfectly, then I'd start the Migration Assistant using the 2017 MBP in Target mode.

The other thing I do, because it didn't work correctly once when I did it a different way..... After selecting the source disk, MA will scan the source and identify the files, accounts, apps, etc. that need to be transferred. Since I was transferring everything, I didn't wait for it to calculate the sizes of all these different things, and just said "Go" or "Next" or whatever to get it started. That didn't work. So, now, I always wait for the scan of the source disk to complete. I wait to see the size of the Users folder, the size of the Apps folder, etc. before I start the Migration.

Good luck!

  • Thanks @Zonker.In.Geneva, will give it a shot this morning. Aug 6, 2018 at 8:41

Finally...got it working.

TLDR; I put the destination machine in target-disk mode, connected it with USB-C 3.1 Male-to-Male cable and used Carbon Copy Cloner to create a new sparsebundle on the root of the drive, than ran migration assistant after mounting it while running a dummy account.

It is worth noting I wanted to do a few things:

  1. Copy my machine as completely as possible (IE all my bash-profiles (I am a developer), and installed frameworks)
  2. Have access to the source machine during the day for work! I don't think this is too much to ask in 2018 for a transfer of 500Gb to run over a LAN or USB-C 3.1 with all modern equipment)

There are A LOT of worthless "Migration Assistant" explanations out there. So I figured I'd post a few details of what I learned this week. This is my experience it may/probably won't work for everyone else. Plus I had the advantage of migrating 500Gb to 1TB which in the end was my saving grace.

Paths I tried:

  1. Open Migration Assistant on both machines both connected to the same router (late model Linksys AC9000) network over CAT5 cables

Result: Migration assistant runs, and transfers to new machine in 2-3 hours. However (same as initial question lots of "Unable to transfer file" errors, when logging in, no Docs, Applications in directories, etc., keychain warning). FAIL

  1. Run Time Machine backup from source machine to external NAS (both connected over CAT5 to same Linksys AC9000 router). NAS is 12TB Symbology

Result: Time Machine taking forever after 3-4 days I attempt to use lowpri_throttle_enabled hack, backups run faster, but keeps looping on "Backing Up" (Both Migration Assistant and Time Machine have USELESS "progress indication" FAIL - Gave up after backing up for 2-days

  1. Go to Apple Store, and as employee: "What does Apple use to migrate machines when customers ask it to be done for them?" Answer: "USB-C, it costs $99, and there is no timeframe, you leave us both computers and we call you when it's done."

Buy generic Microcenter Inland brand "Super Speed USB 3.1 10 Gbps" USB-C Male to USB-C Male (Apple Store DOES NOT STOCK a USB-C 3.1 Male-to-Male cable as of this posting)

Connect machines with cable, and put source in 'Target Disk Mode' (Hold "T" key while booting), open 'Migration Assistant' on destination machine.

Result: Migration Assistant relatively quickly manages to collect source-information calculations (User Account, Application, Network Settings, etc. and sizes for each - though this does not seem to have much practical effect it takes A LONG TIME) Start migration, Migration assistant shows "Starting Up" for 3-hours, no change, or estimation or copy-speed indication. FAIL

  1. Download Carbon Copy Cloner, I was suspicious of 3rd party back-up tools being capable of working appropriately with Apple's convoluted back-up scheme and sparse-bundle file format, but CCC 5 is definitely an excellent tool, so shameless plug to them! There is also a free-trial so you don't have to pay to use it full-featured for 30-days, but you should buy a license and save yourself the brain-damage of dealing with Time Machine.

Result: Create new backup on NAS (Same Symbology 12TB NAS as before), since my Time Machine backup indefinitely never finished after 4-days. Wait (not as long as Time Machine) but overnight 4-5 hours over LAN CAT6 now. Open Migration Assistant on target machine, attach network drive, see my backup, and wait.

Migration assistant says: "Loading Backup" for 12-14 hours, I cannot click "Continue" as it is deactivated. I can see network traffic moving from the NAS to the computer and so on, but after 15 hours I give up. FAIL

  1. Put destination machine into target disk mode, and connect with USB-C 3.1 Male-to-Male cable to source. Format target drive, remember it has 1TB of space, and backup is only ~500Gb. Open Carbon Copy Cloner, and create new back-up on root of attached target-disk drive. This takes about 2-hours (relatively fast compared to other attempts). Attempt to boot into recovery (Discover machine just hangs at the Apple Spinning Globe screen, until I place backup sparsebundle inside of a directory on the root of the drive, I just call it backup/macbook-pro-2017.sparsebundle

Result: I than reinstall MacOS, and create a dummy account (as suggested by @Zonker.in.Geneva) and than boot, run updates, verify that I still have my .sparsebundle archive, than I "mount it" (Double click it in Finder), and than open Migration Assistant.

Now I see Macbook-Pro-2017 as a source, I select it, and it very quickly manages to do the size calculations. I start the migration once they complete, it's worth noting that as a developer I have A LOT of tiny files (it calculated 3.5 million in the sparsebundle),

Migration takes ~12 hours. Again the time/progress indicators are WORTHLESS. Sometimes it says reading 130mb/s, sometimes nothing. Sometimes 3 days to finish, sometimes 3 hours. It's completely worthless.

Finally, I reboot the machine and it says "Migration Complete" and magically, I am able to login to my account as if I was on the original machine, and it appears so far that everything is as expected.

The big caveat here is that I had a 1TB machine as a destination for ~500Gb worth of files, and after migration I only have about 50Gb of space left before I delete the sparsebundle. SUCCESS, now if I could only get the last week of time I spent messing around with this back. Thanks for the productivity bump Apple. 🤯

  • Does this change at all with Catalina? I just tried to migrate using a USB-C cable and that failed with a vague error message. Also, I've read that TimeMachine connected over to a NAS can have issues. Did you try TimeMachine connected via USB? Jan 4, 2020 at 18:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .