0

yesterday i turned off my computer as usual nothing strange yet ive noticed that it get so hot lately ( I figured out later that it’s due to dirt in fan , i cleaned it ) ; then today morning computer stucked in a black loop after apple logo , it shows in a half second cursor then it turn. Black again , i tried safe mode ( stucked in same loop )and repairing disk and reinstalling macos i tried alt command R+P and nothing worked , i didnt install anything yesterday yet i ignored an update from apple from last week ; im using sierra , i need help please , and thank you so much in advance

11
  • Can you get into Recovery mode? Was autologin enabled? If so, the "resetpassword" command typed into Terminal may help you. Disregard the part about Recovery Disk (unless your Mac is that old). You may have some cleaning up for the user account.
    – Trellis
    Aug 5, 2018 at 23:56
  • BTW, you have to launch Terminal from the Utilities menu once you get into Recovery mode.
    – Trellis
    Aug 6, 2018 at 0:11
  • Thank you trellis for you answers yes i got into recovery mode and i reset password but nothing changed
    – Oudib
    Aug 6, 2018 at 0:40
  • Was autologin enabled?
    – Trellis
    Aug 6, 2018 at 1:54
  • how old is the computer? do you have a hard disk or an SSD? If you have a hard disk, and it's old, then it's possibly (probably?) dying. Replace it, migrate from the old disk to the new, and you'll be fine. Aug 6, 2018 at 9:02

1 Answer 1

1

It sounds like the OS might corrupt hence failing to boot, you can verify this by booting up using verbose mode to see where it gets stuck at.

To fix the actual issue I think you should boot into recovery mode and do a re-install of the OS (formally called Archive install) This shouldn't delete any data but if you had a backup then good. Here are instructions

https://support.apple.com/en-gb/HT204904

1
  • Hi maximus thank you for you answer , i boot in recovery mood i tried to install using command r nothing happened and option command r after installation done it shows a apple logo and a wheel and it stucked there , i tried shift option command r to install lion back but it says that my hard drive has lastest version ...
    – Oudib
    Aug 6, 2018 at 22:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .