0

I use an iMac running macos High Sierra. I was trying to do something with my Documents folder and I turned off iCloud on my "Desktop and Documents" by unchecking the box in the System Preferences/icloud/option window as shown below.

enter image description here

Once I finished I wanted to turn iCloud back on by clicking the above checkbox. However, it will not turn back on. When I click on the checkbox the checkmark appears as shown below and a message saying "Setting Up..." appears.enter image description here

But if I close System Preferences and then reopen them, the checkmark is gone. Can someone tell me how to turn iCloud on for "Desktop and Documents"

1

Here's a description of what happens when you turn off Desktop & Documents folder. It might simplify things to move all the stuff that went into the Desktop and Documents folder that was created into the default Desktop folder or Documents folder (or distribute the items between those two folders), then delete the new Desktop and Documents folder to make things the way they were before the option was enabled originally. Then I would suggest logging out and back in before attempting to enable Desktop & Documents folders in iCloud prefpane again.

  • i tried emptying both Desktop and Documents folders but it still won't work. I'm out of things to try. After emptying both folders I restarted my computer but still no luck. Thank you for your reply though. – jmh Aug 4 '18 at 23:51
  • I have found articles on turning it off and back on and they make it sound like a simple procedure but it doesn't work on my machine! – jmh Aug 4 '18 at 23:54
  • There's a Desktop folder and a Documents folder, then the folder named "Desktop and Documents". I'm suggesting that you remove the "Desktop and Documents" folder from the Home folder (but not until you move its contents elsewhere), then be sure both the Desktop folder and the Documents folder exist in the Home folder. Then put a check mark into Desktop & Documents folders in the iCloud prefpane. – Trellis Aug 5 '18 at 0:01
  • Are you sure about a folder named "Desktop and Documents"? I don't have a folder named that. I created one but it had no effect. I then deleted it and still no effect... – jmh Aug 5 '18 at 0:25
  • I guess it might be the "iCloud Drive (Archive)" folder, depending on your actions. Try removing contents from that if it exists, then deleting it. – Trellis Aug 5 '18 at 0:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .