1

So I recently had to reinstall my OS on my MBP. After the reinstall I attempted to open Chrome, but it would not open...I forget the error message. It was like there was a file missing or something. So, I tried to reinstall it and this was a struggle too, since I had to do it multiple times before it took. One of the things I had to do was delete the old copy of Chrome and I used App Zapper for that, since I could not remove it any other way. After deleting the App, I ended up with a bunch of folders in the Trash that I cannot delete no matter what I try. These folders are mostly empty with the exception of one which is basically full of what appears to be folders containing all the various languages that Chrome supports, however those folders are all empty too. When I try to delete these files, I get a message saying that they cannot be deleted because they are being used, yet when I check Activity Monitor, I cannot find them anywhere. I do not use Chrome often, so i don't understand how these files can be in use but they can't be found running anywhere. I have taken them out of Trash, put them in a different folder that I renamed and tried to delete them, but nothing. I have tried commands from the Command Prompt, like -rm and I don't remember what else, but that doesn't work. I have uninstalled Chrome again, and tried to delete them and nothing. What can I do? [enter image description here] [enter image description here]2 [enter image description here]3 [enter image description here]4 [enter image description here]5

And this just continues through all the language files, so you get the idea... So let me reiterate, NONE of these files are actually in use no matter where I search for them, I can't find them. So how do you delete files that not being used but the OS claims they are....?

Here is the result of the rm -r * Terminal command: enter image description here enter image description here enter image description here enter image description here

  • Have you rebooted your Mac? Have you checked if there are any instances of Google Chrome or Google Chrome Helper running in activity monitor? – Scottmeup Aug 4 '18 at 15:02
  • I have the identical problem but I obtained it in a different way. I asked a similar question but received no answer. If you get an answer please let me know... – jmh Aug 4 '18 at 15:02
  • I've rebooted but the problem still remains... – jmh Aug 4 '18 at 15:03
  • I have rebooted numerous times, that does nothing. I have uninstalled and reinstalled Chrome, that does nothing. If Chrome is running, yes, Helper is running in Activity Monitor. I stop that process and try to empty the Trash, that does nothing. I stop Chrome from the Activity Monitor and then try to empty the trash, that does nothing. – Manfred33 Aug 4 '18 at 15:41
  • JMH, I feel your pain... I'm asking this question on numerous websites and nobody seems to have the answer.... – Manfred33 Aug 4 '18 at 15:42
1

How about:

  • Type the following with empty space at the end into Terminal:

    sudo rm -rf

  • Drag the files you want to delete (from the trash) into the Terminal window and hit ender.

  • Enter your password. Done?

Disclaimer: Caution! The in this way deleted files are deleted forcefully and cannot be back easily. But I think you want exactly that...

  • Tried that one already.... same results as I posted at the bottom of my original post. – Manfred33 Aug 4 '18 at 16:55
  • Yeah, sorry, I see... Thought the "f" argument would help. Maybe repair disk via recovery mode / installation disk (on older systems) since it states that those files don't exist...? But this is a shot into the blue, I don't know if this will help... :) – Jeremy Bear Aug 4 '18 at 17:00
  • Unless I am doing it wrong, but I think you need to be more clear as far as the empty space at the end... should the cursor be immediately after -rf or should there be a space after -rf and then the cursor? Does it even make a difference? – Manfred33 Aug 4 '18 at 17:00
  • No matter how I try it though, I don't get prompted to enter my password... And i know what you are talking about, I have been given that prompt before so.... – Manfred33 Aug 4 '18 at 17:03
  • About the question on the space: You type "sudo rm -rf ", with that space at the end and then drag your files anywhere in that window. Then you should be prompted for your password. (If you have no password on your account then you temporarily need to set one in the system preferences for it to work, I think... Dumb, I know.) But you say, that nothing happens at all afterwards? That's strange... Does Terminal need to be force quit?! I still recommend a disk repair in disk utility of the recovery mode [(Opt +) Cmd + R] at the Mac chime when you reboot. – Jeremy Bear Aug 4 '18 at 17:13
0
  • Open Terminal
  • cd ~/.Trash
  • ls and verify that these are indeed the files/folders in the trash
  • rm -r *
  • I tried your solution but when I did ls it listed nothing! – jmh Aug 4 '18 at 16:36
  • Nope, doesn't do it... I tried something similar to that before and got the same results. I took a screenshot and will try to post it. – Manfred33 Aug 4 '18 at 16:39
  • Alright, so I couldn't add the screenshots as a comment, but I edited my original post to include said screenshots.... – Manfred33 Aug 4 '18 at 16:48
  • Even better than screenshots would be copy/paste the text – nohillside Aug 4 '18 at 17:14
-1

Try using /Applications/Automator to create a System Service to delete items immediately.

When you create a new document in Automator, choose Service as the type. For "Service receives..." in the pop-up at the top, select "Files or Folders", and in the App pop-up choose Finder.app.

Add the "Run shell script" action. Settings:

Shell: /bin/bash

Pass input: As Arguments

script contents:

for f in "$@"
do
rm -r "$f"
done

Save the service with a name you can find easily, such as "Multi_instant_delete". Open the trash folder, select the unwanted items, perform a contextual click on one of them, and choose "Multi_instant_delete" from the Services item in the pop-up menu. You'll be prompted for your admin password.

If nothing happens, you could try executing the same steps while logged in as root. To temporarily enable the root user with /System/Library/CoreServices/Applications/Directory Utility.app, open Directory Utility, click the lock and authenticate, then choose "Enable Root User" from the Edit menu. You will now see "Other" in the login window, which you will choose, then enter "root" as the user name, and the password you assigned using Directory Utility. After you have logged in as root, you can view the .Trash folder in the home folder of the account of the user with the issue. You may then be able to select the items and move them to the trash then delete. If you can't see the items, you may need to search for .Trash folders that exist elsewhere on your boot volume. You may want to create the Service as the root user. When you create the Service, you may need to move it from "/var/root/Library/Services" to "/Library/Services" for it to appear in Root's contextual menu. Use ⇧⌘+. to see the .Trash folder(s).

Try leaving the original user logged in first, and if that doesn't work, then try by logging out of that user's account before logging in as root.

Be very careful when using that Service while logged in as root! Don't forget to disable the root user in Directory Utility, if desired.

  • Well, I have tried something in Automator that was suggested by somebody else, and I probably didn't do it right, because I look at that app and am just bewildered with it; kind of over my head. I will give your suggestion a shot though and let you know.... – Manfred33 Aug 4 '18 at 17:22
  • Well, I tried it, following your instructions as best I could... Gave me some error messages in a pop-up window.... I took a screenshot but I don't even know if I can post an image in comments... I'll post it at the bottom of my original post. – Manfred33 Aug 4 '18 at 17:29
  • That would appear to be taking us in a different direction. Did you try the Show Workflow button? If you can, let us know what happens when you do. I'm wondering if this might be simpler after you perform a fsck on the boot volume. Simplest way to do that is startup with the shift key down until the Apple logo appears (Safe Boot). Safe Boot isn't complete until you restart normally. Somebody didn't like my post, maybe it seemed like there was too much risk involved in some of the suggestions, and there is quite a lot of risk, for sure. – Trellis Aug 4 '18 at 18:23
  • One more idea, is your problem account a non-admin account? Surely it's not too objectionable to suggest temporarily making it an admin account until the problem is solved. Are you sure your Service workflow contains a Run Shell Script action and not a Run AppleScript action? – Trellis Aug 4 '18 at 18:27
  • No, it is an admin account as far as I know. – Manfred33 Aug 4 '18 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .