1

I have an old iMac running macOS High Sierra 10.13.6. My internal drive was filling up, so I connected a 4 TB external drive.

On my internal drive, my Documents folder contained about 8 GB data. I created a Documents folder on the external drive and moved the contents from internal Documents folder to the external Documents folder, clearing up some space.

However, the internal Documents folder was connected to iCloud. Is it possible to connect my external Documents folder to my iCloud account? If so, how do I do this? I know I can login to my iCloud account and create a new folder and upload files to it. Problem with that is that I have many folders in my new Documents folder, and it won't allow me to upload folders so I'm looking for a way to make the whole Documents folder attached to icloud.

1

You can move the Documents folder to the external drive and create a symbolic link to Documents folder present on the external drive in your Home directory.

Follow the steps mentioned below:

  1. Move the contents of the internal Documents directory to external Documents directory.

  2. Rename the internal Documents directory. (You'll need to do it via Terminal by executing mv ~/Documents ~/Documents-old as Finder won't allow renaming.)

  3. Open Terminal and create a symbolic link to the external Documents directory in your Home directory.

    ln -s /Volumes/<EXTERNAL_DRIVE>/Documents ~/Documents

Now verify that the iCloud sync is working all-right. The old internal Documents directory (which was renamed in step 2) can be safely deleted.

  • I did as you suggested but when I do a 'ls -lrt' then Documents folder does not show as a link. The external documents folder shows as drwx------@. Does the @ symbol imply link? – jmh Aug 4 '18 at 14:32
  • How do I tell if it worked? – jmh Aug 4 '18 at 14:33
  • @jmh Using the command mentioned, the symbolic link named Documents should get created inside ~/Documents. Can you verify if that works? – Nimesh Neema Aug 6 '18 at 13:12
  • From ls man page, If the file or directory has extended attributes, the permissions field printed by the -l option is followed by a '@' character. – Nimesh Neema Aug 6 '18 at 13:15
  • Yes, that worked. So I deleted both documents folder and used -F option in the ln command to create the folder. That worked. To do so I had to turn off the option to have "Desktop and Documents Folders" synched to iCloud. But now I can't turn iCloud synch back on! How do I do that? – jmh Aug 6 '18 at 13:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .