89

How do I disable the display of popup which appears when holding down a key? It slows my typing speed and makes me do so many mistakes in my writing and programming. I need it at time when I wish to enter an alphabet twice.

enter image description here

3 Answers 3

110

In macOS, when a key is held down while entering text, a popup is shown which lets one choose between various accented forms of the character. To disable this execute the following command line in the Terminal.app:

defaults write -g ApplePressAndHoldEnabled -bool false

Now, you'll need to log out and log back in. This should disable the display of the popup and character typed should start repeating when the key is held down.

If you ever wish to return to this behaviour, execute the following command line in the Terminal.app:

defaults write -g ApplePressAndHoldEnabled -bool true

You'll need to log out and log back in again for the setting to take effect.

5
  • 1
    thank you! i have a problem in Intellij products because of this feature: after I press and hold some letter button on a keyboard, any code editor pane is disabled for text input. now, the problem fixed. thank you again. Commented Oct 24, 2018 at 2:26
  • 1
    Is there a way to map holding the letter onto a specif one of the popup items?
    – Joel H
    Commented Feb 12, 2020 at 12:32
  • @JoelH I am not aware of any built-in way. It may be possible with the help of a 3rd-party tool.
    – Nimesh Neema
    Commented Feb 13, 2020 at 2:54
  • 2
    Note: you don't seem to have to log out and back in, just restart any apps where it doesn't take effect immediately (some seem to not need to be restarted at all).
    – jjj
    Commented Jul 12, 2021 at 17:09
  • 1
    Thanks, I feel like this should be an option in the Keyboard settings, but Apple is Apple I guess.
    – Rino Bino
    Commented Sep 11, 2023 at 17:53
1

I solved this problem by turning my keyboard off and then on, and the special chars window went away; now it only shows if I press and hold a key for a few seconds (like it should); before, it was showing every time and there was no way for me to remove it.

My guess is that a keyboard key got stuck sending the pressed signal or something like that.

1
  • This is not a bug, it's a feature.
    – Thinkr
    Commented May 25, 2023 at 16:52
0

If your accent menu appears immediately upon pressing a key, not after holding the key for a few seconds...

Solution was to change the keyboard repeat duration very slightly so that it saved a new number. It was as if the Mac thought the setting was zero (0) i.e. repeat instantly.

Settings > search: "repeat" to find 'Hold before repeat duration'. It was already set to 3.00 seconds but I changed it to 3.10 seconds and [Done]. After this the accent menu only appears after holding a key for 3.1 seconds, instead of instantly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .