0

I recently installed Julia on my iMac running High Sierra. Julia seems to want to run in the Z-shell whereas I normally use bash. I haven't run Julia today but my Term2 windows are screwed up since installing Jullia. It used to be that when I was using iTerm, the command line listed the name of my current directory followed by the cursor. Now when I use it the command line contains a long character string. If I run bash, the command line returns to normal. Any hints on how to get iTerm from starting in the Z-shell. An image of the terminal has too small print to read... The cursor line used to look like so:

my_user_name/computer_name:/Volumes/MyBook/Applications$

but now it looks like:

\[\033[36m\]\u\[\033[m\]@\[\033[32m\]\h:\[\033[33;1m\]\w\[\033[m\]$
  • Julia runs in any shell. ITerm Profiles->Open Profiles shoes the setup. If you edit the profile it shows which shell you are using and the start parameters – Mark Aug 2 '18 at 21:14
  • I tried that but there is no mention of the z-shell. – jmh Aug 2 '18 at 21:25
  • How are you starting bash rather than zsh in iTerm – Mark Aug 2 '18 at 21:29
  • Yes iTerm sources a .bash_profile file and i've set options somewhere to start in bash shell. Its been working fine for years until I installed Julia. – jmh Aug 2 '18 at 21:37
  • i just fixed this in the preferences for iTerm and Terminal. I changed from login shell to command. In the command box I put /bin/bash. This fixed the problem. I'd still like to know why I have to do that... – jmh Aug 2 '18 at 21:47

You must log in to answer this question.

Browse other questions tagged .