40

My new MacBook Pro suddenly stopped recognizing an external monitor (Dell U2515H) after 2 days of normal usage.

Yesterday, after I was done with my work, I closed the lid as usual and today, I opened the MacBook and the external monitor didn't get detected.

The monitor is connected via USB-C -> HDMI cable (cost about 20$).

I have already tried restarting my Mac, reconnecting the monitor and detecting monitors in System Preferences. I have also tried resetting SMC and NVRAM. Unfortunately none of it worked.

Detailed info:

  • MacBook Pro (2018) - 15", i7
  • Mac OS High Sierra - 10.13.6
  • USB-C to HDMI cable
  • Monitor: Dell U2515H

Any help is highly appreciated as I really need my external monitor for work.

10
  • I think the most productive thing to try would be to connect the adapter and display to another MacBook Pro of the same type to see if the replacement MacBook Pro works. Also, when you performed the NVRAM reset, was anything other than the power supply connected? If you're not sure, try it again with nothing other than the power supply connected.
    – Trellis
    Aug 3 '18 at 1:24
  • @Trellis Thank you for your reply. Reseting the NVRAM with nothing connected didn't help. The problem is that I don't have another MBP and I don't know anyone with same MBP.
    – Phyber
    Aug 3 '18 at 6:54
  • The only really reliable way to identify a problem with a hardware configuration is to isolate devices and replace each one. That's much more difficult, of course, when you're the only person you know with the same hardware configuration. Apple store might be able to help, because they can duplicate your Apple products (computer and adapter), or come close. The first step I would take in your situation would be to be sure the display works with any other computer. If it does, you might then consider taking all three components to an Apple Store Genius.
    – Trellis
    Aug 3 '18 at 22:55
  • 1
    @MdaG Unfortunately not. Still trying to find a solution to this. I have ordered new cables to try, however none of them came and my order has been cancelled. Maybe try starting a new question, hopefully someone who can help notices it.
    – Phyber
    Aug 30 '18 at 17:35
  • 1
    All of this can be resolved by using an active adapter instead of the cheaper dongles/cables etc. If you can avoid HDMI, you should - at all costs. No conversion = greater reliability.
    – Allan
    Nov 2 '20 at 16:45

15 Answers 15

43

Similar issue with Philips monitor, MacBook Pro 2017 TB, and Digitus USBC-DP dongle. My solution:

  • Remove the power cable from the external monitor, wait 5-10 seconds, put it back in.
13
  • 13
    I feel so silly for having to upvote this, but indeed this was what worked for me. I have observed the problem on both a 4K Asus panel (VP28UQGL) and a 4K corp panel (Google brand). I had even tried different cables and USB-C ports, but simply unplugging (and waiting several seconds!) was the resolution. Apr 29 '20 at 10:19
  • 2
    Same as @PaulLammertsma. After attempting various fixes (e.g. different ports, restarts, reset NVRAM/SMC), unplugging the power cord for my HP Z27 monitor for around 20 seconds resolved the issue of my 16" MacBook Pro 2019 not detecting my monitor. It feels very silly.
    – David
    May 18 '20 at 13:22
  • 1
    This worked for me. My environment: - HP Z27 - MBP 13" 2017 - CalDigit docking station Jun 29 '20 at 14:23
  • 3
    ridunkulous, but this worked! Thank you, @felice.
    – taranaki
    Dec 5 '20 at 17:45
  • 5
    I cannot believe this worked lol !!
    – Nick Div
    Dec 20 '20 at 8:24
13

This might seem silly but this worked for me (also better to exhaust all options):

I use a dock connected into the thunderbolt port. My charger connects into the dock and so does the monitor (dp to mdp cable). My Dell U2715H suddenly stopped working too. I tried a bunch of different things but nothing worked. I decided to take my laptop to a service center. I just happened to remove my charger from the dock first (with the monitor still connected) and suddenly the desktop showed up on my monitor and every thing was working fine. I just connected my charger back and everything was back to normal.

3
  • Amazing! I spent so long trying so many different things and this fixed it for me. Thank you.
    – duffn
    Dec 18 '19 at 14:54
  • Weird. For me I swap the adapter that has monitor hdmi and charger and it works
    – phuwin
    Mar 27 '20 at 8:34
  • This worked for me on a 2018 MacBook Pro and a display connected with a USB-C -> DisplayPort cable. Mar 29 at 6:25
1

Fix for me:

  1. Leave both MacBook and monitor connected and powered on
  2. Wait until MacBook display turns off (can probably tweak energy settings to force)
  3. Press a key to wake, and both displays wake up

Detailed info:

  • MacBook Pro (15-inch, 2017) - 2.8GHz i7
  • Graphics - Radeon Pro 555 2GB
  • Mac OS - Catalina 10.15.7
  • Monitor: Apple Cinema HD 23"
  • USB connection - Bastch DVI>USB-C adapter
0

I had the same issue with Macbook Pro w/touchbar, but with 2x Dell u2415Q (both stopped working at the same time). They are connected via 2x Kanex USB-C to DisplayPort female dongles; then using standard DisplayPort cables from there.

After much faffing around, the solution ended up being to simply disconnect the dongles, from the cables, and reconnecting at the dongle level. I had tried disconnect from Macbook, and disconnecting from the screens, but didn't try disconnecting the middle connection (separating the dongles from the cables and back again).

All up and running again. Hope it helps someone!

0

I had same problem. Spent an hour with Apple tech support, we finally figured out I needed a USB-C to miniDisplay port dongle, not the USB-C to Thunderbolt 2 dongle I purchased with the new MacBook Pro. (Outward appearance of the miniDisplay port and the Thunderbolt 2 port are the same.) Once I had the right dongle, the monitor worked immediately.

0

I had this issue for HOURS and was going crazy. Ended up the fix (for me at least) was downloading the latest video driver for Dell (my monitor is Dell), and that fixed it. So have a look and see if you can download any drivers :-)

0

The same malaise hit my external monitor today. The only crime I did was to unplug the Mac from the dock and plug it back into the dock later. No display --after weeks of this sequence followed successfully, and new gear (one month old display, cable, docking station).

  • MacBook Pro (15 inch, 2018)
  • MacOS Mojave 10.14.6
  • Dell 4K UltraSharp Monitor, U2718Q
  • Uni DisplayPort to USB C cable
  • CalDigit TS3 Plus with Thunderbolt 3 cable

Troubleshooting

I spent HOURS today trying every combination of troubleshooting under the sun. The basic troubleshooting strategies applied were:

  • Confirm display: connect to another computer (worked)
  • Confirm display cable: didn't have another USB C computer to connect to (skipped)
  • Simplify: eliminate everything in the chain possible, get it working then add back. disconnected docking station, connected display directly to computer (didn't work)
  • Confirm computer: reboot computer, try plugging, unplugging display into computer (didn't work)
  • Confirm power: I have seen references that higher resolution displays cannot be supported without direct power for your computer. In other words computer may disable hi res displays on battery power. So plug in your computer using its power supply. (didn't work)
  • Drivers/OS updates: It was a working and stable configuration for some time, with no intervening updates before it stopped working, so don't destabilize the environment by changing drivers before troubleshooting. (skipped)
  • Diagnostics: Apple -> About this Mac -> System Report... -> Hardware -> Thunderbolt / Power. EXTREMELY USEFUL. lets you see the Mac's view of what is connected. Before I eliminated the docking station I was able to see the CalDigit connected and supplying power, but no display connected even though the display was connected to the CalDigit.
  • Connection sequences: Tried rebooting computer with display disconnected, connect display to computer directly (didn't work). Reboot computer with display connected (didn't work). Power cycle display while connected to computer (didn't work).
  • Detection: Try having each side detect the other. Power cycled display on boot it reported no DP device detected. Googled to find the magical hidden Apple button to detect external displays (System Preferences -> Displays -> hold down Option button to cause magical button Detect Displays to appear), nothing detected. (didn't work)
  • Recent history: Nothing changed on my computer (at least that I initiated). The hardware I had been using for the last couple of weeks successfully (display, docking station) had no changes.
  • Power cables: I know this sounds stupid, but check each point in the power chain. The docking station has a transformer which plugs into the power strip and then the transformer plugs into the docking station. Don't forget to check both. Similarly the monitor has a cord with two ends, make sure both are snug. In my case all the troubleshooting loosened the plug into the docking station transformer. (didn't work)

What Worked

The aggregate of the successful answers here suggested this was a power sequencing issue. I finally tried powering off the power strip and powering everything back on at once. Viola! Display popped up immediately. At this point I was in the simplest configuration: display connected directly to laptop and no docking station.

Given all my troubleshooting I believe the culprit was the Mac itself. The display and cable were working, it was the Mac that got into a state where it could not see external Thunderbolt devices.

Epilogue

Sadly I just checked the Mac System Report and Thunderbolt still reports no devices connected to its bus ports. But in the middle of everything it did see the docking station. So it's not the panacea I had hoped as I can see some things correctly but not others of significance.

CalDigit docking station after all the troubleshooting just died. The blue LED doesn't light. The Digital Optical port on the back which is lighted is no longer. Either the transformer gave up the ghost, or the dock itself fried from all the connecting and reconnecting. I love the product design and features, but I have one at work, and it's been flakey on occasion (refusing to power up like now).

0

Late entry here but it might be useful to someone so here we go.

If your computer has been working with an external monitor but suddenly stopped supplying an image feed

Problem & Tinkering

I have a late 2016 MBP 15 running Catalina 10.15.4 connected ta an Eizo CG248 via a displayport - USB C connection. It has worked without issues for over a year. Then at one point I closed my mac and turned of the screen, opening the mac up again the screen is not recognized at all. Screen is blank and turns it self off after signaling "no input found".

As I used to work in a store selling apple computers I tried all the regular tricks. Rebooting everything connecting, disconnecting, trying to force find the screen. Resetting SMC and p-ram to no avail. I did have a hyperdrive, laying around with a HDMI out. Connected it and got an image but only with 30hz refreshrate that I wasn't able to change, so it wasn't a viable option, as I need 60. The hyperdeck specs said it would provide 60hz via usb out but for some reason it did not and the HDMI cord was a 2.0 one. Tried again with 2 different display to usb c cords. And bought a mini displayport to displayport. Through the hyperdeck also got a 30hz refresh rate. Other computers in the household connected to the screen fine. But not my work computer and it was really annoying.

I realized that there was one option I hadn't tried, if it was the hyperdeck that was resticting the HDMI i could try a HDMI - usb c cord capable of 60hz. So I got one and. I got an image.... At 30hz.

I thought I'd try again to connect the displayport - usbc and.... It worked. What?! All the glory in resolution and refreshrate was back. And it has been working since! So it seems that my computer for some reason had a hangup that was cured by connecting another type of cord, but in my case not through a hyper deck. I then returned the cables I bought since I didn't need them and now I'm back to status quo with my original hardware.

SOLUTION

Go buy all the cord variations you can connect between your monitor and computer. Try them out one by one and retry your original connection in between. Then simply return the cords you don't need to the store again. If it works it works as It did for me. And it's free to try.

Hope you all get your image back!

0

Ridiculously the solution for me, which I discovered purely out of frustration, was to use short, sharp taps (2x) on the F2 as opposed to a slow single tap which had worked previously. Now that works every time. I know it sounds ridiculous but this issue was doing my head in and that is was I accidentally discovered! very low tech solution!!

0

Tired of constant reboots that always help, resetting SMC, plugging/unplugging cables, the faster solution turned out to be:

  • Close the lid
  • Connect miniDP(not tested on HDMI or USB-C, but hope is the same) and attach power charger
  • Don't open lid until external monitor turns on by click on mouse button or press any key on external keyboard, after that you can open lid
0

I recently experienced the same issue: a new work-issued 16-inch Macbook Pro stopped recognizing a Dell monitor connected using an HDMI cable and a multiport USB C adapter.

I confirmed that the monitor and HDMI cable were fine by connecting them to another computer, tried two different multiport adapters (this one from StarTech and this one from Anker) in all four Thunderbolt ports (notably, all the non-HDMI ports on these adapters have consistently functioned without issue), reset the NVRAM (as suggested in Apple's troubleshooting instructions for external displays), and tried power cycling the monitor as suggested in the top answer.

The only thing that worked for me was:

  • Unplug the monitor's HDMI cable from the multiport adapter.
  • Turn off the monitor (it was not necessary to unplug it).
  • Wait the usual 10 seconds or so.
  • Plug the monitor's HDMI cable back into the multiport adapter.
  • Wait for the MacBook's screen to briefly flash black.
  • Turn on the monitor.

Since the first time I stumbled on this solution, the MacBook has repeatedly failed to detect the external monitor (usually a few days after the issue last occurred) and these steps have resolved the problem every time.

On a cantankerous note, I feel obliged to note that the prevalence of this issue (assuming a google search is representative) is disappointing given the expense and corresponding implication of quality of Apple hardware.

0

Had the same problem - MacBook suddenly stopped sending signal to external display.

My setup:

  • 16'' MacBook Pro (2019)
  • HP U28 4K HDR Monitor connected via USB-C (with power delivery)

Monitor was working perfectly for a few days, suddenly stopped working - says No signal detected.

Solution: With the monitor connected to the laptop, turn off the monitor, unplug monitor's power cable. Plug power cable back after 10 seconds.

Thank you @felice !

Sidenote: Besides the HP monitor, I had a second monitor connected (worked fine the whole time). This was an older Samsung connected via HDMI using a USB-C -> HDMI dongle.

Get a Mac they said... It will just work they said...

0
  1. Install displaylink (https://www.synaptics.com/products/displaylink-graphics/downloads/macos)
  2. Restart Mac & Login
  3. Go to Launchpad
  4. Click on "DisplayLink Manager" - your monitors should come on
0

What worked for me is to reset Mac's SMC.

Intel-based Macs have a System Management Controller (SMC) that can be reset as a possible fix for Thunderbolt Display issues.

These instructions are for Mac notebooks with non-removable batteries.

  1. Shut down the Mac.

  2. Plug in a MagSafe or USB-C power adapter to a power source and to your computer.

  3. On the Mac's built-in keyboard, press the left side Shift+Ctrl+Opt and the power button simultaneously.

  4. Release all the keys and the power button at the same time.

  5. Press the power button to turn on the Mac.

If this does not fix you can try also to reset the NVRAM (persistent ram). https://www.macrumors.com/how-to/reset-thunderbolt-display-smc-nvram/

3
  • Thx for the update. You mention in your original post that you tried resetting the SMC but it did not work. Why do you think it worked when you tried again later on?
    – Alper
    Nov 14 at 19:44
  • I didn't mention that I tried resetting SMC before... I tried the first time and it solved the problem (dockhub via thunderbolt not recognized).
    – NicoKowe
    Nov 14 at 21:55
  • Are you referring to another SMC in this part of your original post? "I have also tried resetting SMC and NVRAM. Unfortunately none of it worked."
    – Alper
    Nov 14 at 21:58
-2

Had a similar problem MacBook Pro 2018, Belkin dock and USB-C HP monitor.

  • go to System Preferences > Software Updates
  • install all pending updates
  • reboot

Now it is working again.

2
  • What exactly do you mean by "all updates"? All updates to what? Also, did the updates include a reboot of devices?
    – nohillside
    Jul 29 '19 at 8:45
  • Welcome to Ask Different and thank you for your answer. :) Unfortunately, short answers such as this don't really provide enough detail or context to help many users. If possible, it'd be good if you could add some more info such as what updates you installed? Also, you may want to read How to Answer for tips on providing answers here.
    – Monomeeth
    Jul 29 '19 at 9:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .