I have a new macbook pro (2018) and want to connect it to my old iMac 2011 using target display mode. I used to be able to do this just fine with my old MacBook pro (mid 2012) that had a thunderbolt 2 port.

In the new set up, I have a thunderbolt 2 cable and an adapter to connect to the new MacBook pro that converts thunderbolt 2 to thunderbolt 3 (USB-C). When i press command + f2 on the iMac, the screen flickers and then just stays black. My MacBook pro recognizes another monitor...so not sure whats happening.

Both systems are running the same OS, High Siera, and I have tried changing the adapter to make sure that was not the problem. Any help would be appreciated because I see that some people have managed to get this to work! Are 3rd-party adapters better at getting the job done?

  • Can we assume everything works to connect the “first display” and everything works when you disconnect the first and only connect the “second display”?
    – bmike
    Commented Sep 3, 2018 at 16:10

7 Answers 7


I have had the same problem with my 13" 2018 MBP to my iMac 27-inch, Late 2012. Talked to Tech support for weeks at the advanced levels. They told me they are working on it and look for a firmware update for both the laptop and the iMac. Bought my MBP when they first came out, it is now September 3, 2018 still no update. Still does not work. Have not heard of anyone finding a work-around. I used to use target display mode with my MB-air and was looking forward to using it with the new high-powered laptop (it was NO-GO).

  • 1
    To be clear - you are saying one adapter won't work at all to have the iMac be a second display for you?
    – bmike
    Commented Sep 3, 2018 at 17:29


This was driving me nuts too. 2010 27" iMac <-> 2018 Macbook Pro using Target Display Mode.

If you are using the Apple Thunderbolt 2 -> Thunderbolt 3 adapter, this will not work, because the iMac doesn't use TB2. . . it uses Mini DisplayPort, which has the exact same plug shape as TB2, but is not compatible for this setup. I got a USB-C to Mini DisplayPort Adapter from Amazon for under $20 and it solved the issue. Hallelujah! Hope this works for you too.

  • 1
    If you have the brand or model number of the adapter that you purchased, others on this thread may be interested in duplicating your success.
    – cgseller
    Commented Mar 14, 2020 at 13:18

I have the same issue with my new 2018 I-9 15-inch MBPs (I have two).

Since around 2012, I have used a variety of 15-inch MBPs with either two 2012 27-inch iMacs or two 2013 27-inch iMacs in target display mode. To be clear, I usually use 2 of the iMacs in target display mode simultaneously, and have never had a problem with any pre 2018 MBP, whether I was using Thunderbolt 2 cables directly plugged into the pre 2016 MBPs or using the Apple Thunderbolt 2/Thunderbolt 3 adapter to plug into the newer ones with the USB-C ports.

I have an active case with Apple that has been escalated to an engineer with no luck yet with a resolution. I will have to return the 2018 MBPs I purchased if this is not resolved as I need to use 2 monitors simultaneously and do not want to replace the iMacs just because the 2018 MBP can't drive them.

You mention some people have been able to get this to work? Can you provide me with details as to how? 3rd party adapters? I would not mind reinvesting in those is that is what is necessary.

  • Unfortunately, I don't know what 3rd party adapters in particular work. And looks like most of the ones available on amazon are for iMacs with display port and not thunderbolt. Maybe people who have gotten TDM to work also have older iMacs (2009-2011) which had the display port connection not thunderbolt (even thought they look the same) I also have an ongoing case with Apple that got pushed to the engineerings. Do keep me updated on what they come back to you with and I will try to do the same!
    – Astar
    Commented Aug 5, 2018 at 21:41

There is an extensive post on this on the Apple Discussion forums. Someone there recently discovered a workaround by daisy chaining their Thunderbolt connection to the iMac. Somehow going through another device cleared up the signal for them. However most of us don't want to (and shouldn't have to) buy an expensive new hub or drive that can daisy chain so keep reporting this to Apple so they fix this issue! Reference the large thread so hopefully they escalate you to an engineer quickly:



The issue is fixed as of Mojave 14.3 (installed on the 2018 MacBook Pro). In fact I believe it should be fixed in 14.1. Note that Mojave 14 does NOT fix this bug - you need to upgrade to at least 14.1.

Source: Personal experience and https://discussions.apple.com/thread/8495379?page=2

  • Mojave 14.1 "fixed" the issue but not for me. I just bought a new 2018 MBP running 14.3, and spent a bundle on getting the cables needed to connect it to my late-2012 iMac with Thunderbolt 2 port, also running 14.3. Once everything is connected, and after hitting CMD+F2 the iMac screen goes black and never changes, no way to bring it back until I disconnect the thunderbolt cable. Anyone else using 14.3 successfully with this setup?
    – B. Findlay
    Commented Feb 13, 2019 at 23:48
  • @BenjaminSinger I was able to get it to work with 14.3. Are you using the Apple "Thunderbolt 3 (USB-C) to Thunderbolt 2 Adapter" adapter? Also are you using a Thunderbolt cable instead of an MiniDisplay one? Both the adaptor and the cable should have the Thunderbolt (lighting) icon on them.
    – Jiahao Li
    Commented Feb 14, 2019 at 10:54

I was having this problem with my 15-inch 2018 MBP running 10.14.4 and 27-inch late-2012 iMac running 10.14.5. Doing a whole bunch of stuff on the iMac (resetting SMC, NVRAM, changing brightness levels) didn't fix it. But resetting the SMC on the MBP did fix it for me.


Try logging out of the account on the iMac and pressing Command - F2 while at the login screen.

This worked consistently for me with a 2019 MacBook Pro on Mojave 10.14.6 and a 2012 iMac on Mojave 10.14.5, with Thunderbolt 3 to Thunderbolt 2 adapter and Thunderbolt cable.

Suggestion came from a thread on Apple forums

Update: I updated the iMac to Catalina 10.15 and tested it. The behaviour is intermittent, but logging out of the user on the iMac always fixes it for me.

Update2: Also, plug-in the MacBook first and then the iMac. After that, you might have to try Command - F2, again.

  • I find it also helps if you plug the cable in at both ends. True story
    – CupawnTae
    Commented Oct 14, 2019 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .