Before the High Sierra update to 10.13.6 I was able to boot in single-user-recovery mode by holding Cmd-R-S at startup, but after the latest software update booting while holding Cmd-R-S just enters the regular Single-User Mode on the root volume (like if I pressed only Cmd-S).

Is there a new method or alternative key combination to boot the RecoveryOS in Single-User Mode?

EDIT: booting while holding Cmd-Option-R-S also starts in Single-user mode (not Single-user-recovery mode).

  • 2
    Interesting, I haven't tried this in a while. Was it definitely still working in 10.13.5? Also, have you tried the other method of booting into single-user-recovery mode (i.e. Hold the Option key during startup to get the Startup Manager and then hold Command + S while you select the Recovery boot volume)? Finally, what model Mac are you using?
    – Monomeeth
    Commented Aug 1, 2018 at 1:02
  • It was working before because I've used it recently (I couldn't say if on 10.13.5 or on 10.13.4 though). Yes I've tried booting while holding Option and then pressing Cmd-S while selecting the boot volume but it still goes into single-user mode: it states Enabling and disabling services is not supported in single-user mode and if you try csrutil disable it replies csrutil: failed to modify system integrity configuration. This tool needs to be executed from the Recovery OS so I'm pretty sure this it's not recovery mode. It's a MacBookPro 17" late 2011.
    – mindrones
    Commented Aug 1, 2018 at 15:54
  • 2
    Ok, so what is it you're actually wanting to do? I mean, why do you want to boot into single-user-recovery mode?
    – Monomeeth
    Commented Aug 1, 2018 at 21:06
  • This is why I need to do this: apple.stackexchange.com/questions/267581/…. Basically I need to follow the instructions in that post to disable a kext that tries to use my broken graphic card hence I can't rely entering recovery mode via GUI.
    – mindrones
    Commented Aug 1, 2018 at 22:43
  • Remaining on 1012 this puzzles me: 1. csr-disable should work in GUI Terminal from RecoveryMode (Cmd+R) as well (Please edit Q to confoirm it does no longer with 10.13.6) 2.: Has Apple now shipped a working X3000.kext with that update again? (All previous updates seemed to have installed akext but a defunct one.) Please comment to reflect that that's the case. Commented Aug 25, 2018 at 11:09

4 Answers 4


I was having the same issue, this is how I fixed it.

As we are not able to get to Single User Recovery Mode by using the key sequence, Command + R + S at startup to run csrutil disable, it is not taking you to Single User Mode.

Start by booting the computer in standard Single User Mode using Command + S. Once you are at the command-line, run the following command to turn off the dGPU:

nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Then reboot your computer by running:


The dGPU has been disabled, so we can now access the GUI recovery mode. On reboot hold Command + R, and it will take us to the GUI recovery mode. Once there, click on Utility menu and open Terminal, here we can run the csrutil command:

csrutil disable

To make the dGPU fix persistent through the next update, make sure to run the nvram command a second time, then reboot by running:

nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

followed by:


Boot into Single User Mode with Command + S to continue with the kext moving procedure. Once done, go back to GUI recovery to enable csrutil, then reboot.

Once Mac fully boots, run nvram one last time as sudo:

sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

and do multiple reboots to test the machine boots back up properly. I have no issues now.

  • 1
    Hi! Thanks for your help. I didn't try it already, but I will need to. I didn't understand how you boot to single-user-recovery, and where did you run the nvram command. On single-user mode?? and then disable SIP on recovery mode? Does the computer load the UI on recovery mode? Thanks
    – Frade
    Commented Oct 29, 2018 at 10:53
  • 2
    If I could give this answer more than one upvote, I would. After hours of frustration and wrong paths, this was the answer that worked for me.To answer Frade question above, log into single user mode with Command+S, type the nvram command above, reboot, then go into Recovery Mode with Command+R. The nvram command will tell the Recovery Mode GUI not to use the GPU. Commented Apr 16, 2019 at 2:47
  • This worked for me on a machine I was sure was bricked! The key is sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00 so you can boot into recovery mode and turn off csrutil. Be aware this will break your screen and keyboard brightness buttons/the ability to change. Resetting the PRAM will break this fix as well. More info about people trying to solve this issue can be found here: gist.github.com/blackgate/17ac402e35d2f7e0f1c9708db3dc7a44 Commented Jun 2, 2020 at 0:12

On my Late 2011 MacBook Pro (MacBookPro8,2), I was able to boot into Recovery's Single User Mode on 10.13.6 by continuously holding down Cmd+R at boot and then a few seconds into the grey screen (but before anything else displays) moving directly to Cmd+R+S, not releasing the first two keys when transitioning. Might take a few tries as the timing is inexact.

To describe the sequence in more detail, my MBP first boots to a solid-grey screen along with the startup chime. After some amount of time (presumably loading) on this grey screen the FileVault decryption fields appear. Here is generally what it looks like once those fields are on-screen:

Login screen (image sourced from Rich Trouton)

Before the fields are on-screen it's exactly the same solid-grey screen but without any other elements on top of it (Apple logo, login items, etc). It takes some time for the completely grey screen to move to what is pictured above. I add S to my key combo between this populated grey screen and the completely solid one. And I noticed that to get it to work consistently I had to add S closer to the appearance of the pictured populated grey screen than to the appearance of the initial solid-grey screen.

I believe newer MacBooks no longer feature a grey screen when FileVault is enabled and instead opt for a black one which eventually becomes a much more attractive login screen with a wallpaper background image. If I had to guess this approach could still work for these MacBooks but I don't have one nearby to experiment with.

The basic generalizable idea is that you hold Cmd+R continuously, press the power button, and then as soon as recovery mode starts you switch to holding Cmd+R+S continuously without releasing the first two keys. The annoying part is that if you switch to the second combination too late then recovery mode stops looking for it and boots into regular recovery. Too early and recovery never boots at all and you go to single user mode on the normal partition. Additionally annoyance is created by the fact that, at least on my MacBook, there is no visual indicator where recovery starts booting and you need to add the S. If recovery's loading bar appears it's already too late to add S.

  • Which grey screen? My MBP boots black. Commented Nov 6, 2018 at 13:55
  • 1
    @MattSephton My Late 2011 MBP boots to the FileVault decryption/password-entry screen which is initially just a solid grey screen and then eventually populates with the password entry fields. I'm not sure if this is possible on newer MBPs or if the timing might be different. I'll update my post.
    – Kevin Mark
    Commented Nov 6, 2018 at 14:04
  • 1
    @MattSephton Updated. Hopefully it helps those on newer MacBooks to develop a key combo timing that works for them (if it's even possible).
    – Kevin Mark
    Commented Nov 6, 2018 at 14:48

Did you try to boot on a bootable installer of a previous macOS version which supported single-user-recovery?

I understand the goal of disabling SIP is to alter /System/. I guess booting in target disk mode and altering /System/ from another Mac bypasses SIP.

  • Stuck in Part 1 of apple.stackexchange.com/a/295805/99309 as well because of single-user-recovery mode unavailable, just succeed moving the Radeon kext using target disk mode. Commented Aug 3, 2018 at 13:31
  • Using the broken mac as target disk I've been able to move the offending kext, restart in RecoveryMode (cmd-R), disable SIP, which then later let me run nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00 and touch /System/Library/Extensions/, so the machine is now running again with the internal graphic card, but it will require having 2 macs after an update to move the kext in target mode, so I'd prefer having a way to enter in single-user-recovery mode directly, but thanks a lot!
    – mindrones
    Commented Aug 26, 2018 at 12:22
  • Is it possible use the broken mac as target disk?? It doesn´t need the graphic card?
    – Frade
    Commented Oct 29, 2018 at 10:55
  • Just had to do it again. Note to self: * follow apple.stackexchange.com/a/295805/99309 until 1.6 * 1.7 : boot in target disk mode instead of single-user mode * 1.8 don't, cd into /Volumes/Your target disk instead * 1.9+ : beware of using relative paths to your target disk to not mess up your actual machine Commented Dec 24, 2018 at 15:32

I am in exactly the same situation for exactly the same reason. My early 2011 MacBook Pro was humming along fine with its dead dGPU until the cursed auto update went to work against my will.

I can confirm the key combo still worked in 10.13.5 as that’s the last time I did the fix.

I’m afraid unless somebody finds there’s a new key combo to get into single user recovery this latest update may have nerfed the bad GPU workaround as documented since it’s vital to disable SIP. I have a couple ideas about how to get around this involving having another Mac and external hard drives but I can’t try them until my kids go to sleep for the night. I will update here if I have any success.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .