0

I have a MacBook Pro with macOS 10.8.5. I am trying to update to High Sierra with a new Apple ID. After entering my Apple ID it says 'This Apple ID has not been used with the App Store, please review your account information.'

When I click Review, it says 'Software update required, to make changes to you need to upgrade your mac to the latest version macOS.'

I dont have any other apple devices to set up my Apple ID with.

  • Can you try to download a free application from the app store first, so it can verify your ID? – fsb Jul 31 '18 at 15:10
1

I assume you are doing that from one of the System Preferences?

If so, log into https://appleid.apple.com/#!&page=signin with that new account in a web browser.

You may have to feed it a credit card or some other payment option because That Is The Way Apple Works (sigh...). Once you have done that you should be able to log in and download the new OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .