0

When then screensaver is activated, pressing a button on the keyboard does not stop the show and display the lockscreen. The system bell chimes, but the screensaver show continues. If I press a button on the mouse, the screensavers stops and the lockscreen shows.

It's been a while, but I remember being able to stop the screensaver by pressing any key on the keyboard. Is there some way to re-enable this functionality?

Edit: I'm running 10.13.6 (17G65) High Sierra.

2

I fixed it by following the instructions from this post, which, oddly enough, didn't come up when I searched for it before making my post.

Anyhow: I did the following:

System Preferences > Mission Control > Displays have separate spaces: checked

Which now allows me to stop the screensaver by pressing a key.

  • Oddly, I've always been able to wake the screen with a keyboard tap [any key, fortunately no 'separate spaces' requirement, which I hate]. Back in maybe Mavericks days a shake of the mouse would do it too, though no longer. Unfortunately since Mojave beta, often neither will work for me. Shake, click, tap, beep beep beep... til eventually something surprises it awake...:/ It might be worth disabling separate spaces again & see if you just jogged something into life. – Tetsujin Jul 30 '18 at 19:38
  • I'm pretty sure that it changed (for me anyhow) when I updated to High Sierra from Sierra. Mouse interactions have always worked to stop screensaver. – jakks0 Jul 30 '18 at 19:41
  • I had Sierra only for a month then nuked back to an El Cap clone; then only a few months ago went from that to HS... which has been such a pain in the *** that I'm currently on the Mojave beta. [There's hope, it's fixed some issues I had with HS, though still beta & has new issues of its own... it's better than the last 2 OSes already, though ;) – Tetsujin Jul 30 '18 at 20:04
  • I filed a bugreport for this (50661344) which is visible at openradar.appspot.com/radar?id=5056554340450304. It was marked as a dupe of 50607597. I dislike the "Displays have separate spaces" option so I'd like to see Apple fix this bug. There are some related and additional notes about this at github.com/JohnCoates/Aerial/issues/768 – luckman212 May 16 at 13:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .