0

I have been using MacBook pro-2017 for about a year, in the mean time I have added a couple of quiclook generators (e.g. QLStephen.qlgenerator) for various services for the Finder.

For quite a few days it was working good, but now, I encountered a strange problem. Nowadays I can not see the contents of any file in the finder, e.g. when I click on a a.txt file it shows no contents, but when pressed Shift key it shows the QuickView of the item.

How to restore the original settings of the Finder?

I tried deleting all the quicklook plugins, but still, the problem is sustained.

Attempt:

cd  ~/Library/QuickLook
sudo mkdir backup
sudo mv *.qlg* backup/
qlmanage -r
killall Finder

PS: I tried also deleting all the contents of QuickLook and restarted the computer. Still it does not work. Maybe I have to reset the Finder settings, but I don't know how?

Note that here the a.txt is not empty but Finder shows nothing.

How can we make the Finder show the contents of this file?

Update Backed up and deleted the QuickLook folders from the computer.

sudo mv /Library/QuickLook ~/library_quicklook
sudo mv ~/Library/QuickLook ~/home_library_quicklook

sudo rm -rf com.apple.quicklook.ui.helper.plist
sudo rm -rf com.apple.quicklookconfig.plist
sudo rm -rf com.apple.QuickLookDaemon.plist

qlmanage -r
qlmanage -r cache
killall Finder

Still does not work.

enter image description here

Related links: https://www.cnet.com/news/fixing-quick-look-issues-in-os-x/

  • The icon for the a.txt file doesn't look like a text file. I'm using High Sierra and my txt files have what looks like writing on the icon. Maybe you still have some other program that's associated with txt files? What does it show in 'Open with' when you do a Get Info on that file? – fsb Jul 30 '18 at 18:17
  • @fsb the icon for txt file is for visual studio code text editor. it should not make problems, IMO. – Poudel Jul 30 '18 at 18:19
  • Try changing that to Text Edit and see if displays the contents. – fsb Jul 30 '18 at 18:54
1

To show contents of a text file you must have the correct settings for your Finder window. You can't use icon view or list view. Your figure shows you are using list view. That view has never shown file contents on my computer. On the Finder header bar there is a label that reads "View", and above that are four icon options: the first is icon view and the second is list view. You want the third option but I don't know what its called. If you select this way of viewing the contents of the Finder window, text files and other types are displayed showing the 1st page of the contents of a file. The correct viewing option is shown in the figure below.

enter image description here

  • The finder is the correct mode, I have uploaded another picture in the above question. It does not work in any mode of views. – Poudel Jul 30 '18 at 18:05
  • There is a difference in QuickLock option and seeing a file when selected. What is your question about? Do you have an application associated with a.txt? Unless you've specified an application for a file with a .txt extension, your mac will not know what to do with the file. – jmh Jul 30 '18 at 18:56
  • Yes, a.txt is associated with TextEdit.app (previously with vscode.app). Finder also does not shows contents of any file, eg. a.py, a.c, a.md, a.f90, a.csv etc. – Poudel Jul 30 '18 at 20:40
  • Well, I'm stumped! I'll keep thinking on it and if I have any other useless suggestions I'll let you know. lol – jmh Jul 30 '18 at 21:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .