0

man timed and "hoakley" says that timed still uses /etc/ntp.conf and I see nothing in the launchd plist that selects that or anything else, so I would think that it is either hard-coded or in some alternate configuration file.

Anyway, in 10.13.6, changing it has no effect on what the pref pane says is being used. And the pref pane only allows one of three Apple servers. Changing that has no effect on ntp.conf  Erasing it causes the USA server to be re-entered (without affecting the file).

So, is it possible to point it to a different time server? If so, how?

  • What was the purpose of your edit, removing a space and adding it back? Doesn't make much sense when it should have been a period. – user3439894 Jun 5 at 0:58
3

In OS 10.13.6, I was able to replace time.apple.com. with pool.ntp.org. in the "Set date and time automatically" field of the "Date & Time" pref pane of System Preferences by highlighting it and typing over it--after authenticating to unlock it, of course. I verified the change in Terminal.app using cat /etc/ntp.conf, which returned server pool.ntp.org..

EDIT: Response to OP’s comment below

In my case, the name of the server listed in /etc/ntp.conf does change immediately upon selecting a different pre-set server in the "Date & Time" preference pane (that is, as long as the "Set date and time automatically" checkbox is ticked).

Out of curiosity, I used sudo nano /etc/ntp.conf to directly edit the name of the server in the network time server configuration file. Although the name of the server in the preference pane remained unchanged, that was the case only until the next activation of timed, when the name of the server I had entered indeed appeared in the preference pane’s text entry field. (I believe timed runs once an hour or upon the system waking from more than an hour’s sleep.) This same sequence of a new server’s name remaining undisclosed by System Preferences until the time daemon runs occurred when I set the network time server using sudo systemsetup -setnetworktimeserver foo.time.foo.

(And, yes, I really am on High Sierra.)

  • This is interesting. Since it had a menu, I assumed it wouldn’t accept typing. Given your experience, it is odd that, even after a reboot, the pref pane does not match the file, and selecting a different server on the menu (instead of typing) does not change the file. – WGroleau Jul 30 '18 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .