1

Bought one of those nifty m.2 adapters on eBay for my 2015 MacBook Pro a1502 so I could save some money on buying an OEM drive by using a cheaper 512GB LITEON nvme SSD. MacBook's firmware is up-to-date, and SSD is detected using ARCH Linux, but refuses to show up in either High Sierra Disk Utility or Sierra/El Cap Disk Utility, all from recovery mode.

What do you think? Not sure why it wouldn't be showing up given it's recognized in Linux. Tried fresh when first arrived, w/partitioning the drive w/in Arch Linux both generically and with Apple HFS/HFS+, still nothing. Have also tried with a 2015 MacBook Air, nada--recognized in Arch, nothing on El Cap/Sierra/High Sierra installers.

  • Maybe something in the drive firmware requires a specific driver macOS doesn't have? Just guessing here but that seems reasonable. – Steve Chambers Jul 27 '18 at 23:50
  • Didn't High Sierra's firmware update add native support for all NVMe drives? Wouldn't be sure why macOS would include driver firmware for other third party SSDs and leave out LITEON. – Hardwood Jul 28 '18 at 1:50

You must log in to answer this question.

Browse other questions tagged .