1

I have Magic Trackpad 2 I use on my iMac 2013 When I bought it worked without problems for a few weeks. But now I have a problem, my iMac recognizes it as trackpad 1

Before

Now!!

When you go to settings then Trackpad has no option for force touch. How can I determine what caused this and/or fix it to I can control the details again?

1

This might need some triage to narrow what you've tried. Restart, new user, apply software updates. Before even that point, you should back up to Time Machine or your chosen backup method.

  • reset the NVRAM and SMC would rebuild the pre-boot hardware and software settings
  • restart the OS cures a temporary situation
  • installing new OS would rule in or rule out software issues

To expand on the initial triage steps above:

I would pair another trackpad (external) since that would tell me if your software or settings were causing this (some trackpads may not even do haptic, so I could see a check to see if the hardware had that and then the software draws what you see intentionally) in which case you would erase the Mac and reinstall the OS - verify the hardware shows haptic and restore your data and apps.

If it's not software, then hardware repair would be needed to see why your trackpad isn't being sensed as haptic since at that point you know your software is good.

0

I tried to find the /System/Library/PreferencePanes/Trackpad.prefPane file from macOS 10.13.5 and all the settings worked again. You just need to rename the file, for example by adding 1 at the end of the name, and open :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .