1

I have to use some very old ERP software (ADS), which is reached via telnet. It uses ANSI colors, and displays normally with the OSX terminal defaults EXCEPT the "normal white" and "normal magenta" are strangely dimmed despite cranking the ANSI colors to the max:

Screenshot

What's so strange about this is that the text at the very top is the correct value of white, but the rest is not. When I drag the color of "normal white" around, ALL of the white text changes proportionally, the text at the top AND the rest of the white text. Similarly, dragging "normal magenta" does affect the magenta text, but it never goes all the way up to what it's supposed to be. In comparison, those who access this via Windows (not sure what terminal) see the correct rendering.

I've checked all the regular things: opacities are all 100%. I tried adjusting every color to see if they have any effect (none). I tried ALL of the terminal types to no effect.

What gives? It's as though there's a second layer over the text dimming it, and yet that text at the top is mysteriously correct!

(Incidentally, I tried iTerm2 yet couldn't get ANY ANSI colors at all!? [I tried every terminal option and relevant character encoding])

  • What happens if you check the box for "use bright for bold text"? I think this may be an APP issue (it's "manually" setting the colors on the screen). Try it with iTerm2 or with a different machine (Windows or Linux). If it stays the same, the issue is with the application itself. – Allan Jul 27 '18 at 20:17
  • I've tried every combination of every setting. None of them have any effect. I edited the post to say that Windows users don't seem to have this problem (not sure what terminal they're using but it is probably just the old DOS terminal) – T3db0t Jul 27 '18 at 20:57
  • On the Windows machines, check to see what Terminal emulation they're using (i.e. ANSI, xterm, xterm-256, vt100, etc.) It's possible the Terminal type needs to be something specific. – Allan Jul 27 '18 at 21:48
  • @Allan I can ask, but I already tried every available emulation. – T3db0t Aug 3 '18 at 14:35
1

OK, I don't know if this is a bug or what, but I found a very effective solution/workaround.

In Preferences > Profiles > Text > ANSI Colors:

Set the Blue (4) color to 0% opacity and then in

Background > Color & Effects:

if I set the opacity to 99% instead of 100%, the previously illegible text looks GREAT. Totally clear and legible, exactly what I wanted. But weirdly, setting 100% opacity makes it completely low-contrast and illegible. Leaving Blue (4) at default is still legible, but lower-contrast.

So again, not sure if the 99/100% opacity thing is a bug, but this works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .