After installing MacOS Mojave Beta, I ran into some trouble installing Xcode 10 beta 4. I need the latest version of Xcode to use common tools like npm, node, yarn, etc.
After I found the install page and waited a very long time, I got Xcode_10_beta_4.xip from the Apple downloads page. Upon trying to unzip this xip folder, I get:
When trying to unzip THAT I get...
Xcode_10_beta_4 2.xip, etc.

The folder won't unzip and I need suggestions on how to get this installed. Thanks in advance to anyone that knows a solution :)


The file was corrupted, that’s why it was opening weird. Because of my slow download speeds, and continual resumes when it kept pausing the download... it got corrupted. After finding a coffee shop with some good download speeds I tried again and it worked perfectly.


That's because .xip is not .zip. See https://stackoverflow.com/questions/40414645/how-to-extract-xip-archive-using-command-line

You can use

xip -x <path/to/archive.xip>

I use https://github.com/danzimm/xip_extract since it gives a progress indicator.

  • I think this will work! Right now the file says it’s corrupted but I’ll try downloading it again and unxip it this way. – Josh Corbett Aug 1 '18 at 13:39
  • I can't remember if I've ever had issues with xip -x, but xip_extract definitely works every time for me. – Scott Mathieson Aug 1 '18 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .