2

I set up iTerm2 colours/backgrounds, however the first tab is always "lighter" (i.e. more transparent) than all the other tabs. When I set transparency in the profiles, I can see every tab except the first one adjusting. Is it some bug or some setting I'm missing?

3
  • 1
    Do you mean the tab itself or the whole window associated to that tab? When I adjust the transparency with the slider in Preferences/Profiles/Window all my tab screens change with the slider. Including the 1st.
    – Natsfan
    Jul 27 '18 at 17:52
  • 1
    Do you have a background image?
    – Natsfan
    Jul 27 '18 at 17:53
  • no background image. i'm using it as visor, so there is only one window, and it's only the first tab, if i open a new tab, it has proper opacity. if i close that first tab, everything is fine, all new tabs are ok
    – ierdna
    Jul 28 '18 at 2:06
3

In my case this was due to HotKey windows was created after pressing hotkey, but after CMD+T new tab was created with Default profile. So you can either set HotKey as default or rework your shortcuts. You can experience with this by clicking right mouse button -> New Window/New Tab and then Default /HotKey Window profile. After you will define what you would expect here it should be easier to configure

1

Just sorted this myself. The trick is in "Preferences > Profiles > Hotkey Window * > Window", uncheck the box for "Open in a new window, never in a tab"

* Note that "Hotkey Window" is just how profile is called for me (using a dropdown terminal), if might be "default" or something else. Try each profile until the one you want is affected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .