28

I'm using a MBP 13" 2014 on macOS high Sierra with a 4k monitor.

The memory usage of WindowsServer can go quite high (up to 40 GB).

The only solution I found is to reboot my computer -- as the memory usage never goes down. The problem started with MacOS Sierra I think.

Does someone has a piece of advice or a better solution than rebooting my computer ?

enter image description here

And after closing all the running apps on my computer, it is nearly the same memory usage: enter image description here

4
  • Tried relaunching your browser? - that's using a colossal amount of RAM too, by the looks of it.
    – Tetsujin
    Jul 25, 2018 at 9:33
  • 1
    Well, I was doing data analysis with Jupyter which explains the memory used by the browser. I just closed all my apps, I have 6.87GB of memory used by WindowServer. Jul 25, 2018 at 9:50
  • 1
    Having the same problem on a mid-2012 MBP running 10.13 High Sierra and just using the built-in display. WindowServer was at about 6 GB of memory usage after 20 days of uptime. Closing Chrome didn't affect this noticeably; after doing so, WindowServer was responsible for more than half of the computer's total memory utilization. Logging in and out reduced WindowServer to 100MB of memory use even after reopening Chrome.
    – intuited
    Feb 7, 2019 at 20:57
  • Further note: display is running at default resolution.
    – intuited
    Feb 7, 2019 at 21:06

1 Answer 1

21

According to this article this appears to be a bug in the system when used with a Scaled Display resolution

This seems to be a bug with scaled screen resolution (specially with 4K monitors) in MacOS High Seirra (and perhaps in older versions of the OS as well). Using "Default for display" screen resolution seems to fix the issue (Not my ideal resolution, but a temporary fix until an MacOS update with a fix is available). More information here: https://www.tonymacx86.com/threads/windowserver-memory-leak-on-high-sierra.233510/

I am using a scaled (external) display and I am facing a similar problem which is what led me to this topic.

10
  • Since I bought a new MBP 15" 2018, I do no longer have the issue (and I try to resell the old 2015 MBP 13'). Even though it does not solve the issue, I tick it as answered since I will not be able to check if one's answer is solving this issue. I a new answer comes up with a seemingly working solution I may change the tick. Apr 11, 2019 at 9:11
  • 16
    Hi All, I've got the same problem with a MBA Retina 13" 2019 macOS Catalina 10.15.1. Any ideas welcomed. Thanks.
    – philippeko
    Nov 26, 2019 at 15:35
  • 9
    I believe I'm still experiencing this issue with an external 4k monitor being scaled on macOS Big Sur 11.0.1.
    – David Gay
    Dec 2, 2020 at 16:39
  • 1
    Still occurring on Catalina 10.15.6. Regardless of the "Real Memory" value, this leak is causing my MBP to start swapping. It took ages to even navigate to this page. Pretty ridiculous bug. Dec 12, 2020 at 6:16
  • 1
    Not sure new hardware is going to fix it @ijoseph. I'm running a macbook air with i7, 16GB ram, Catalina and WindowServer sits at 25% cpu when I'm doing nothing on the machine with a 4k unscaled monitor. Running YouTube full screen, over FIOS it glitches. My 6 year old MacbookPro runs better which is disappointing. Last mac I will use. Too many variables using USB dongles for HDMI. Wish they had a dedicated video port. Jan 5, 2021 at 15:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .