The flop: I was running a linux VM under VMware Fusion 3 on my Mac OS X Snow Leopard laptop. The VM was located on an external hard drive. The laptop battery died and the system went down.

The turn: After plugging in the AC adapter and starting up the laptop (WITHOUT the external hard drive plugged in). Fusion complained about the missing VM file(s), so I closed the VM and Fusion. I then reinserted the external hard drive and tried to start the VM. Fusion froze for a couple minutes, then I got an 'internal error' from Fusion. So I closed Fusion and tried again - same thing. Then I restarted the laptop - same thing. Then I tried starting a different VM (located on my laptop's HD) and Fusion froze for a bit and then said "The connection timed out." I rebooted and tried starting a local VM again - same thing. So now I can't start ANY VMs...

The river: After hopelessly searching the Internet for solutions, I decided to upgrade to Fusion 4, to see if that would solve my problem. Turns out I can't even do that. When I try using the 'Upgrade from v3 to v4' option in the DMG, I get an error message: "A virtual machine is running with an older version of VMware Fusion." Despite the fact that VMware Fusion is NOT running, nor are any VMs (verified by running 'vmrun list' from CLI).

So...what to do, what to do. Any suggestions?

  • Reminds me of apple.stackexchange.com/q/26284/9058 which seems to remain unresolved. Did you contact Fusion Support about this issue yet?
    – nohillside
    Dec 7, 2011 at 22:16
  • Patrix - yes, I saw that. The part about not being able to install v4 is similar, but there's no mention of v3 not working at all. And I have not yet filed a support request - my license was issued to my manager and he's out on vacation for the next week, so I can't submit any support requests until then. Blah. I could just purchase a v4 license and expense it out and then submit the support request, but I don't need v4...ideally, I'd just like to figure out what the problem is and get v3 working the way it was.
    – lupine313
    Dec 7, 2011 at 22:33

2 Answers 2


Fusion uses lock files to prevent multiple processes from modifying the same files at the same time, as could happen if you tried to run to copies of Fusion (say version 3 and version 4) at once. When Fusion quit abnormally, as it did when your laptop battery died, it left behind the lock files and you need to clean them up manually.

See this support article for how to clean up Fusion lock files. If that doesn't solve it, do a Spotlight search including system files for files whose names end in .lck and if they look like they belong to Fusion, delete them.

sudo pkill vmware
sudo pkill VMware
sudo pkill vmnet

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .