I think this is similar to this question, but I'm having a slightly different problem.

I've been using an external LaCie drive for my Time Machine and SuperDuper backups. But I was getting messages that the Time Machine drive was full, and the SuperDuper runs out of room.

I went into LaCie Backups.backupdb and grabbed a bunch of old Time Machine backups and dragged them into the trash.

Trash has been trying to delete them for over 24 hours with no end in sight. So I stopped it and tried to bring the files back in to Backups.backupdb, but it won't let me.

So I've got all these files I can't trash, but can't put back.

Any ideas?


2 Answers 2


So, as an answer, save any other data on another drive, then reformat and partition the drive.

You shouldn't be able to put any Time Machine files into the trash in the first place, so if that happened, you need to get anything you care about off that drive and erase it anyhow. If you don't need the backups - you can use Disk Utility to just erase the drive - that will empty your trash instantly as well as all the data on that drive.


I had the same problem. Tried to trash old Sierra backups and certain files got stuck in the trash. However, when I tried erasing and then re-partitioning the backup drive, I lost the OS for my working drive! While Disk Utility was erasing my backup drive, the erased drive disappeared and then the working drive disappeared... and access to my computer started to go out, app by app... I powered off (power-button) in case Disk Utility was trying to erase more... After powering up in Recovery, Recovery would not work, so I went into an older drive that still had Lion on it... and got into my computer that way. I accessed Disk Utility and RENAMED the backup drive, and clicked Repair on my working drive, and when it told me the drive was still ok, I then powered off and went into Recovery to try and re-install a copy of Sierra to my working drive, but my working drive BOOTED UP NORMALLY. The renaming of the backup drive solved the problem and everything is as it was. The backup drive is clean, and the trash on my working drive is EMPTY.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .