1

This question already has an answer here:

I have two Mac Book Pro's laptop with me.

In one of the laptop, I am getting the following popup prompting when I try to change the login options.

It is prompting me like this:

enter image description here

In my another Mac Book Pro, it's simply showing the prompt like this. So I guess, it should show the same prompt message in first Mac Book Pro too.

enter image description here

How to get administrator name to login into the first laptop? I tried with possible usernames & password (I have never changed my password) that I am aware of but they are not working.

How to find/get the administrator name back so that I can log in with my password.

marked as duplicate by Tetsujin, nohillside Jul 24 '18 at 8:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    From the screenshot, it appears that your first laptop does not have an administrator account. This may not actually be the case (e.g. there might be a hidden admin account, or it might be joined to a network domain and some domain accounts have local admin privileges, or...), but without more information it's really hard to tell. What is the history of the first MBP (especially, how are/were its account(s) set up)? – Gordon Davisson Jul 23 '18 at 6:36
  • Hi @GordonDavisson, thanks for your reply. To my knowledge, my first laptop doesn't have a hidden or domain account with it. Is there a way to find it out? Or is there a way to get the access back for that laptop? You can ask me for more informations you want and I will update my question with it. – Hemang Jul 23 '18 at 6:41
  • You can check for domain setup in Users & Groups preferences by selecting Login Options (under the user list), and what the Network Account Server section says. How did you set up your account on it? Normally, if you just go through the standard setup, it creates your account with admin rights (like on the second MBP). I'm really leery of trying to recommend fixes without knowing what went wrong. – Gordon Davisson Jul 23 '18 at 6:43
  • @GordonDavisson, thanks again. Actually, in my first laptop, I tried to change the account name when I'd access first. I saved the changes and changed the laptop name and account name too. But even after my restart, it's still showing me the old username. And now, it is not allowing me to login to make changes. – Hemang Jul 23 '18 at 6:50
  • Changing the account name is a Really Bad Idea. Changing the "Full Name" is fine, but don't mess with the account name. See here for how to create a new admin account, then use that to change the name back to exactly what it was before. – Gordon Davisson Jul 23 '18 at 8:06
2

Go to your terminal and type the following command in:

dscacheutil -q group -a name admin

This will list the admin username.

  • Hey, thanks. It actually listed the admin username but then the real problem comes, is there any default settings for all the admin users? To my knowledge, I have never set an admin password. Or is there a way to reset it? – Hemang Jul 23 '18 at 7:26
  • There is a way to login and reset the password through recovery mode...though I see you've answered the question yourself anyways. A bit sorry about being late on this one.... – quantum.cmptr Jul 24 '18 at 8:23
1

I have followed the accepted answer to this question: Changing my administrator user's username has removed privileges and it helped me to create an admin account. Eventually, I am able to manage the problematic account.

  • 2
    Please mark as solved – JBis Jul 23 '18 at 16:18

Not the answer you're looking for? Browse other questions tagged .