I am running macOS Sierra 10.12.6 on a MacBook Pro (15 inch, 2017) with 16 GB of RAM, a 256 GB SSD and Radeon 555 dedicated graphics.

I've tried and failed to install both the macOS High Sierra and macOS Mojave beta multiple times. Each time, I have to reinstall macOS Sierra from Recovery Mode and restore my Time Machine backup. I have tried upgrading from within macOS Sierra and performing a clean install of the said operating systems from a flash-drive. The error I get - a flashing folder icon with a question mark at startup - is the same with both methods. This is because my internal SSD is not recognised as a Startup Drive (it's missing from the Startup Drive Utility in Recovery Mode) after macOS High Sierra is installed. I can confirm that High Sierra is installed by going into the Recovery Menu and checking the contents of the SSD.

As I've said previously, I have tried installing from within macOS Sierra where the installation converts the SSD with a macOS Journaled filesystem automatically into APFS during installation - this has failed. I have also tried doing a clean install i.e formatting the SSD, reformatting it as APFS and then trying to install the new OS. Predictably, this fails too with everything going swimmingly until the final restart which brings you into the macOS High Sierra environment; alas! the question mark folder again.

I've tried to explain, as best I could, my issue with updating from Sierra to High Sierra and Mojave. Any help would be tremendously appreciated. I can't schedule an appointment with an Apple Genius as I don't reside in a country where Apple operates a retail store.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.